Unexpected process termination

activities
p_qa

#1

When I run my robot It occasionally gives me an unexpected process termination error and then crashes.
In my windows event viewer It seems to be related to an error in ntdll.dll

Name of program with error: UiRobot.exe, version: 2016.2.6232.26799, timestamp: 0x588618de
Name of module with error: ntdll.dll, version: 6.3.9600.18233, timestamp: 0x56bb4e1d
Exception code: 0xc0000374
Displacement with error 0x000e6054
Process-id 0x3f88
Programs startup time 0x01d29bd3b40d1a4a
Program path: C:\Program Files (x86)\UiPath Studio\UiRobot.exe
Module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report-id: 392de7fe-07c7-11e7-8294-b88a60553353
Full name of program with error:
Relative program-id for program with error::

(This is a translation from danish)

The workflows in question open quite a few browsers in parallel and then, also in parallel, scrapes data from each page.
Is this something I can work around, or is it an issue with the robot?


#2

This may not be of much help,but I had issues with using OCR and I was told to use the OCR activities in a separate workflow. Do you see any such kind of heavy duty tasks in your project?

Also check if the machine in which the Robot is running needs any updates.


#3

The “heavy duty” tasks are basically navigating in the browser and scraping, but this is already being invoked from separate workflows. But it is being done in parallel. I did recently run an update from UiPath studio.


#4

I am facing the exact same problem in my project. I have several “Find element” running in a parallel activity and It makes the program crash. Did you fix the problem? Do someone know what is the problem due to?


#5

Hi,
Facing same issue. The Robot crashes.

Our scenario: Using the ‘Element Exists’ Activity in 6 pick branches with an additional delay pick branch within the pick activity. The same BrowserSession object is being used for the AttachBrowser parent of the Element Exists activity.

On debugging the issue to see the error, the following is logged:
Unhandled exception at 0x77C2A8B9 (ntdll.dll) in UiRobot.exe: 0xC0000374: A heap has been corrupted

Any pointers to a solution or the reason why its happening?


#6

We are facing the same issue. Has anyone got a solution to this problem??
@badita


#7

Same here - it seems like parallel is not ready. Can someone else provide alternative?


#8

I would like to see the workflow that crashes the robot.


#9

@Gabriel_Tatu,

I’m sure if you build a process that screenscrapes yahoo page title, and you include in in parallel with 5 browsers, let it run (on random 5-60 min) it will crash IE or UiPath.exe

I get that you want something specific, but looking at people reporting the error including myself it will give you different workflows that all use something in common “Parallel activity”. I can’t share mine because it’s pretty large - but if I get a chance to extract just a piece and can provide it to you - will do.


#10

Robot has some memory limitations, so when working with large amount of data, in 5-6 parallel activities, i can understand why it crashes.
Its the same thing when you read a very big excel file.


#11

@Gabriel_Tatu - even though technical side of me says I understand, other one says 5 browsers doing a search and getting one data element … crashing IE or UiPath.exe means you have memory leak and your parallel is not working as expected.

I would not have pushed this further if you had alternatives, but you do not. So, I’m stuck with one browser no parallel and telling my business I can’t meet their expectations due to my product limitations. As you can see, its a hard sell to justify UiPath especially when my SVP asks me to look into other products.

I’m hoping to see some of these issues fixed in next release (forum has pretty long list) … and before we get “put it up for vote” or “we are fixing them already” … I get it, just saying - its frustrating when activity exists but does not work as expected. Would hate to see my favorite RPA tool heading direction of frustrated users.

Thanks for trying to help though, I appreciate it.


#12

Parallel activity has its own limitations too. I m not sure if this scenario is really bug or not until i can reproduce myself but i would like to share some details about this activity
https://msdn.microsoft.com/en-us/library/system.activities.statements.parallel(v=vs.110).aspx


#13

Thanks @Gabriel_Tatu,

I’ve spent a lot of time understanding Parallel Activity and how its used. Let me know if you are able to reproduce it yourself. I’ve also opened ticket with UiPath and I’m planning to share my log in case that helps (need to remove PII data).

UiPath.exe crashing - robots faulting should not be caused by Parallel Activity. Graceful restart or fail is what should happen. UiPath crashing on server means manual intervention and until service is started nothing else can run.

Interested to find out if you can reproduce it.


#14

i have run the attached wf for ~30 min, no issues. i need more details from you guys. you can edit the wf and add those activities that make the robot crash on your end :slight_smile:
Main.xaml (16.8 KB)


#15

@Gabriel_Tatu - this is not parallel. Browsers open one at the time and it’s sequential. I’ve modified your code to use true Parallel and it crashed IE. CPU was at 98%. I’m sending image of crash (cellphone because my computer locked up) along the zip file of the code change (all I did is made browser as separate XAML file and invoked that - vs inline). It ran for approximately 10 min. !Parallel.zip (3.4 KB)
IECrash|690x430


#16

this is why i wanted a workflow from you


#17

This is more of a safeguard when a crash occurs, but you can set the UiRobotSvc to restart automatically in services. An admin on the server should be able to set that up.


#18

seems to work fine for me, for now. i have 18.2.3 (latest release) where we did some memory improvements for robot. i don`t see memory leaks, crashes or errors, still running strong
as a side note, IE has a lot of memory issues, so the fact that it crashes does not mean its related to UiPath.


#19

@Gabriel_Tatu - I’m on 2018.1.1 - this could be the reason - since you said you fixed some memory issues. I ran the same process, without parallel - just invoking opening browser and closing it, ran it since last time we talked (about hour) and did not crash IE.

So it seems it crashes only if I use parallel activity. I might need to do an upgrade (which is not an easy thing to do) and see if this helps.


#20

it still runs on my side.