Unbale to fetch confidence score for extracted data


I’m extracting data from Invoice using Document Understanding and I need to add Present validation step only if confidence score is below 60%. Every time output coming as “Index was outside the bounds of the array”. Please help on this.

Thanks in Advance.

There is some fields without extracted values.
To present the validation you can check both confidence level and if field has extracted values


I guess there is no data to be extracted in the value. If so, how about to check if value.Values.Count is not 0 in advance?


Hi @rikulsilva ,

Please suggest me how can I check whether field has value or not ?
It is extracting till payment_terms values and next field is empty there I’m facing issue

You can validade using Any method

First you check if value variable has values

In If activity = Not value.Values.Any or value.Values(0).Confidence < 0.6

I have used the above solution as well but still facing same issue

If control evaluates from left to right that means it evaluates first value.values(0) and here is the problem

Try to put value.Values.Any first like my preview example


Can you try to check it in advance as the following.


1 Like

As I’m extracting Table values as well, Is error coming due that reason ?


Tried but same issue encountered.

I think no. For tables it is another property.

If you try the example provide by @Yoichi probably it will work.

I’m replying from mobile and can’t provide example right now

Tried that as well but same issue.


Which activity throws the exception? Can you share screenshot of it?


If possible, create a new process using Document Understanding Process Template and open post processing workflow to check some examples about validating fields, table and confidence, may help you

I can reply with example later

Sure I’ll try, Thank you!!

Hi @vivekrb131 ,

Could you also maybe take a look at the below post, although it is not about the confidence, but about accessing indices and what to do when there are missing values :

Hi @Yoichi,

This is worked after creating completely new Process. Thanks for the solution.


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.