Unauthorised while browsing the workitem

I want to navigate Each WIID and want to extract the client info details but when i click the browser say url/unauthorized. Where in console I am getting a correct WIID. but not in the browser. Unauthorised

Hi, is that number 260075 available under the work items?

That error usually comes when you try to access a page which is not available. Could you share a screenshot of that workitem if available in the grid? the Column you should check is “WIID”

Thanks and Regards,
Parvati Thalal

please find

Hi,
Try giving with out any space in between item/"+WIID this should work,

Regards,
Pavan H

same result. (https://acme-test.uipath.com/unauthorized) :frowning:

Hi,
what is the WIID value that you are getting?

Also can you try with type into to the browser search element and enter and see if that works.

Regards,
Pavan H

can you log/writeline the whole navigate to url that you have used (copy from the box and add it)?
i think there is a space which would be causing an issue.

The unauthorized occurs when you trying to access the page which doesn’t exist.

Couple of questions/possibilities for error:

  1. In the Read Range, why you are reading from A1:A16, why the range is fixed here?
  2. Can you check in the excel, if the first row contains headers? So it leads to unauthorized page. In that case use read range from A2:A16
  3. Even WIID value is empty string, it leads to unauthorized page.

Please check.

Regards,
Karthik Byggari

1 Like

@ramkrishna2k3 were you able to resolve this issue?? I am facing the same issue too

Hi @Santa_Krish
I suggest you output what WIID is before the navigate. If this value is incorrect, then you will have a problem loading it. After you see what this value is (like with a Write Line or Message Box), MANUALLY type in the url and check the page to see if it works. If it doesn’t work manually, then you might need to reset your test data and ensure the WIID exists and that you can access the page manually.

Hope that helps identify the issue.

Regards.

1 Like

Thanks a lot @ClaytonM. That worked like a charm.

1 Like

I have same problem unauthorised page and when i try manually clicking the vendor tab itslef showing unauthorised page only

You probably need to reset your test data on the ACME site. Either that or the WIID you are navigating to doesn’t exist on the site.

i have the same issue…i tried whatever u said …the WIID i get cant be found among the Work items…when i checked the orchestrator that value was found not among the new ones but the last succesful item.
the item doesnt exist on the site anymore