Unattended robot - Click browser works the first run, second or third run it stops working!

#1

I have this scenario: a simple click within a browser. Attended mode it works perfectly fine always. Unattended mode it works the first time. Then the next run it stops working. It is a simple click activity.

Any ideas? I am running Win10 and UiPath 2018.4.2

#2

I’ve tried focus, show, activate, attach window, attach browser, clicking image, normal click, sending esc keys, resetting windows explorer, killing and opening again the browser… I am running out of ideas, seriously!

#3

@swilliams9 are you using Chrome for the automation? What error if any is thrown on the second run?

#4

Hi Frank, this is IE, and there are no errors at all unfortunately… it just doesn’t click - btw, I have tried Simulate Click on/ff, Send Msg To Window on/off, etc

#5

@swilliams9 would you be able to share your code just to get a better idea of what might be happening. Because from what I understand now if no error is thrown then the selector is found and maybe the control isn’t ready for some reason.

#6

It’s quiet a simple workflow. Perhaps it has to do with the combination of Win10 plus this version of UiPath. This is the list of activities:

  1. Open Browser
  2. Attach to Browser
  3. Click

First runtime it works… then second/third one doesn’t anymore, so weird! :confused:

#7

@swilliams9 Okay if that is all it’s doing the attach browser might be the problem! How are you looping through the iterations?
Is the click opening a new page? Check the HTML-Title of the page after the click against the title in the attach browser.
You could try only lopping through the attach browser part and not opening a new browser for each iteration.
Not sure without the code though :slight_smile: