Unattended bot is not able to recognize window pop up

I have written a process to upload excel files on a website. Process open the respective web page and click on the upload button. After clicking on the upload button Window pop-up gets open.


Now Issue is when I run the process with the unattended bot, bot is not able to identify this window pop up. Element exist activity for this pop-up always returns a false value. Bot does not recognize any of the fields or buttons present on this pop-up. But when I run this process from the studio, the process gets executed successfully. Bot recognizes this pop-up and perform required actions. Can someone help me resolve this issue?

Hi @sandyk,
I’m not sure what exactly do you mean by the unattended robot but every interaction with UI is an attended automation type, which means that it needs to happen with an active user session.

Sorry for the confusion caused. Let me rephrase the scenario.
I have created a process that logs in to a web application. After successful login, it opens a page and clicks on the upload button. After clicking on the upload button, a window pop-up gets open, and using this pop-up bot select a file and upload it. I have deployed this process on a VM. I access this VM using the chrome remote desktop.
The issue is when the chrome remote desktop browser is minimized, the process is not able to identify the window pop up from where the bot picks the file to upload. When the chrome remote desktop browser is in maximized status, the process works fine.

As I assume you are probably on the Studio Community Edition right? Using CE version the Robot service is installed under the user mode which means that when you are not active in the session (the minimized session is working like a sleep mode) the service is not working. This is one of limitations for CE. You can for example install the Robot using the MSI installer.

I am using the enterprise edition.
image

I have few queries.

  1. How can I find out if bot is installed with User mode or Service Mode?
  2. If bot is installed with User mode, can we change its type to Service mode?
  3. Will changing the installation type from User mode to service mode help me in resolving this issue?

Sorry for my wrong assumption. To check how is your robot deployed you need to check your Windows services and check under which user it’s working. If it’s your username then you need to reinstall your robot using the msi package.
image

Hi, I have uninstalled UiPath and reinstalled it using msi package. Still, I am facing the same issue. Please have a look at the below image.

Am I missing anything?

All seems to be ok from this site. I would like to understand more about this chrome remote desktop. Could you tell me how is this working?

I have created a process and deployed it on a VM. I access this VM using Chrome remote desktop. I open the chrome browser and from there I access VM. It is like accessing a remote machine using Chrome browser instead of RDC. The issue which I am facing is that if I minimize the chrome remote desktop browser, the process fails to recognize window pop up. The process can successfully identify the rest of the UI elements and perform click and type operations.
I have gone through “Executing Tasks in a Minimized RDP Window” and did the necessary changes, But still, I am not getting any success.

I am having a similar issue with Remote Desktop. Can anyone help us in solving the issue?