Unable to Vlookup in Uipath

I dont have hard requirement of this Index#.

If BOT click based on attributes value (“MMY” in this screenshots) I am fine with it.

Do you mean I need to declare “MMY” as a variable and pass as dynamic in click activity.

Do you mean I need to declare “MMY” as a variable and pass as dynamic in click activity.

  • Yes the same for Index if you choose Index.

Why I am getting below error.

image

then Should I remove all the add Index# step.

I have tried with the attribute Value variable in Anchor Based activity but BOT is not click on desired value.

seems like GCSR_5 is null. HoverOver the exclamation mark.

One question about the flow.
Once we do step 2, should we compare only the current row from Sheet1 with all the rows in Sheet2 to find the correct one or after each extraction from SAP we schould compare all rows from sheet1 to Sheet2?
Scheet2 will be different for each row of Sheet1 because it is extracted from SAP every time.

Yes, You are correct.

I have Hover on the mark. It is telling only Faulted.

GCSR_5 giving me null value

Now getting below error.


image

Hello Asitabha,
Here I have multiple ways how to do VLOOKUP:

Thanks,
Cristian

Over here I would like to filter “Type” = CCR.
image

I have attached filter wizard activity. After run in Debug mode it is giving me all green tick but data
not filtering from the excel.

image

Every thing seems fine in my WF.

This dt is in sheet3 , I would like to save in Sheet3 itself with new dttable.

But no luck…


Please note you have checked “Remove” option which removes the rows with CCR in Type column.

Are you sure GCSR_5 is not null like in the previous reply?

As you mentioned, I have tried "Joint Datatable " activity and its works fine.
Now, I have tried to remove Type = CCR from the datatable, but its not working.

I have selected “remove” button in Filter Wizard but its not working.

As you can see both the data table has join,


but when I am trying to remove CCR from column Type , its not working.

image

Are you sure you are writing the GCSR_6 Datatable to the empty Sheet in excel?

I have created new datatable GCSR_6 but sheet remain same (sheet3).

Shot me the WriteRange activity with properties which is writing the table to Sheet3

Here it is.
image

I will check on my end, it seems that filtering is not working or there are some data already in sheet3.
Can you set a breakpoint on the WriteRange activity and on the left side of the studio click on the table GCSR_6 to see how it looks right before writing to excel?