Unable to use Web Scrapping on Windows 10


#1

Dear Experts, I have installed the community studio on my 2 systems, one is running Windows 10 and other Windows 7. The Data Scrapping from Website is perfectly working fine in Windows 7 where as in windows 10 I am getting the below Message Prompt while running the script:

One or more errors occured

I am trying to pull data from Amazon.in via Chrome. I m able to perform every step but facing the issue while running the automation.

Its working fine with the other system running windows 7.

Please help me.


#2

if your using chrome then i hope you added the UiPath Extension.
Could you please attach screenshot of it.


#3

Thanks for your reply. I have already enabled the chrome extension.

The moment i click on the RUN button throws me an error (after aprox 5-7 second). It doesnot moves focus into the chrome window. I have attached the screen shot and the error log for your reference.

Please help

Screen Shots


#4

I’m sure this is not causing the problem but anyway try this.
From the snapshot i can see the you checked private option from the property could you please uncheck and try.
If this problem persist again then i suggest you to restart else repair the UiPath Studio.
Everything works by restarting :smiley:


#5

Not getting success. Tried everything, even tried with Firefox. Is there any issue with Windows 10 or Mcafee Antivirus??


#6

Did you check this?


#7

Thanks. There were some problem in installation and McAfee antivirus. I have reunstallwd windows. Now its working fine.


#8

Hello - same kind of thing…we are working on an automation to get stock prices from Yahoo Finance. The automation is working perfectly most of the time, but then once in a while we get an AggregateException error after Chrome opens. We have the Chrome extension. We are on Windows 7 Professional. We are using the latest version of Studio. This is only a intermittent error…but it is frustrating. Can anyone tell us if we need to update something or if we just have to live with this?


#9

Hi,

another approach. You can also retrieve the data via the yahoo-finance-api (e.g. REST component within UIStudio)

This is described here:

You can include this within your roboter. Then you don’t need to use web scrapping.

Br,

Dennis


#10

Thank you. This is OK for Yahoo Finance/Stock prices but what about other web pages? We don’t want to struggle with this AggregateException error here and there ad infinitum. We don’t even understand what the error means. Please help - UiPath??


#11

Hi,

you are absolute Right. I just also tested Web Recorder on Windows 10 with Edge Explorer. Doesn’t detect the logical elements within the explorer. Habe you also tested it with Firefox ?

Br,

Dennis


#12

Hello and thank you for using UiPath Studio. For now, detection of Metro UI elements is not supported, you can try getting individual selectors using UIExplorer.


#13

Hi Gabriel_Tatu,

sorry I don’t really get your explaination. Windows has two surface systems:

  • Windows 8 Modern UI (earlier called "Metro“): optimized for user surface in “tiles style”
  • Classical Desktop surface with windows task bar

My questions:

  1. In Windows 10 Modern UI is scipped by default and I also don’t see any tiles form as starting screen. Also don’t really get what Internet Explorer has to do with the surface system as I thought IE, Firefox etc. (web browser) come along with their own surface systems (web browser, html). Can you please explain a bit more in detail what you mean ?
  2. Does this mean that it is not possible to use data and web scrapturing when starting Windows 10 in Modern UI Mode ? As already said Metro is scipped by Default when starting the system.

Br,

Dennis Suhari


#14

For metro UI (windows 10 interface) we don’t yet support detection of elements - for example calculator, calendar or desktop shortcuts. If sometimes they do work, its an exception.
Anything else under windows 10 related to uiautomation should and will work as expected - browsers, desktop apps, java and so on.
Windows Edge also is not supported, yet - we are working on it.
I m not sure what you mean by : “is scipped by default”


#15

Hi Gabril_Tatu,

you say:
“Anything else under windows 10 related to uiautomation should and will work as expected - browsers, desktop apps, java and so on.” Well that is what I said. UIPath doesn’t detect browser elements anymore.

Br,

Dennis


#16

what browser exactly?


#17

Microsoft Edge


#18

Bingo :stuck_out_tongue_winking_eye:…As of now Uipath doesn’t support edge .


#19

We are working on this, keep close for news


#20

Thanks for info.