Unable to use TypeInto Activity on Excel Prompts screen

Hi All,
I need help with TypeInto Activity while using Excel Prompts.
Instead of single text field been selected, whole area of Prompts is selected.

I have tried various ways to reach the text field. like clicking on the label before the text field. But cursor doesnt go to desired text field.

Can someone suggest me some tips to get this peace working. I have spent like 2 days now on this issue.
Attached is screen shot.
Section 1 - where Excel Prompts is located in Excel workbook.
Section 2 - Period From and To text fields
Section 3 - When trying to use TypeInto Activity, entire section of prompts is selected and not the Period from or To Text field.

Kind Regards,

@Rubot

Welcome back to our UiPath community.

I worked with similar application and also faced same issue. You need to follow below steps to automate this kind of application.

  1. Use Click activity and Indicate Period From from left-hand menu.

  2. And then use Type Into activity and don’t indicate any field in the application and keep selector as empty and pass value as below.

         "[k(tab)]24.10.2021"
    

And follow similar approach to enter Period To value also.

@lakshman thanks for your reply. I will try that now.
When you mean keep selector empty is Type Into right?
Just remove everything from Edit Selector e.g.

Kind Regards

Hi @lakshman I get following error message when selector is empty
Enter Period From: The target Element was not specified for this activity. You should set its Target property or use this activity inside of a scope activity (Attach Browser, Open Browser, Open Application, Attach Window, Get Active Window, Element Scope activities).

@Rubot

Drag and drop Type Into activity and pass below value. Don’t indicate any value.

          "[k(tab)]24.10.2021"
1 Like

@lakshman Thanks for the quick reply.
Your given steps worked and I am able to type into the fields without selector.

1 Like

@Rubot

Glad I could help. Happy Automation :grinning:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.