Unable to uninstall Uipath from Programs and Features

Hello,

In my laptop, Uipath doesn’t update itself automatically. For this reason, I wanted to delete program and install updated version of it. I tried to delete Uipath from Programs and Features, when I clicked the delete button, nothing happened. Then I tried to install updated version without deleting old version. Installer opened and waited for a while and closed. Now, I am checking the program, version of the program is updated but program doesn’t open. I am trying to delete it again from Programs and Features, I can’t delete it again.

I tried steps in here: How can I properly uninstall UiPath community in order to fix UI Explorer? But it didn’t work.

Hi @AnnaDewitt,
If it’s community edition then remove data from:

  • C:\Users\<user_name>\AppData\Local\UiPath
  • C:\Users\<user_name>\.nuget

And before starting new installation make sure you have the latest .Net Framework installed on your computer. If no, then install it and reboot your PC.

It didn’t work btw.

It looks like for some reason your windows registry keeps some data. Rather looks like Windows issue. Is it personal computer of company’s pc? If the second option it might be that you have some restrictions set by IT dept.

It is company’s pc but it was working before this problem happen.

Ok, you can try this but It’s extremely inappropriate method. But since I can’t explain how to work with registry then this might be the only one possible.

So remove (or do backup) of data from these locations:

  • C:\Users\<user_name>\AppData\Local\UiPath
  • C:\Users\<user_name>\.nuget
    and
  • C:\Users\<user_name>\AppData\Roaming\UiPath

This should take effect on Add & Remove Program which now should tell you something like "this application has been uninstalled already, would you like to remove it from this list as well?"

Then download latest version from Automation Cloud Resources page and install it. Now it should work fine. If not then I’m pretty sure there need to be some restriction on you PC and it’s better to ask IT dept. in your company to help.

Thank you for your help. I did everthing you said but problem still continues. As you said, it is probably because of my company laptop.