Unable to stop the job in orchestrator schedule as the job is running continuously

Hi,
I am trying to run a job through Orchestrator Scedule.
While adding the Schedule below are the options that I have choose.
But the bot is running continuously.


Ideally When I am giving Trigger time as every 1 minute and Stop Job After 2 minutes,
then there should be 2 runs in orchestrator.
correct me if I am wrong.

Choose Kill instead of Stop. “Kill” will terminate a job immediately. But with “Stop”, the job will run until it meet the “Should Stop” activity in the project :smiley:

I have tried with Kill also, but there is no change in the outcome.
Can you share an example to use should stop in the uipath studio project so that ‘Stop Job’ can work in orchestartor.
Thanks

@Abhilash_6057
Should Stop is used like this:

This is incorrect. The stop job parameter applies to each individual job. So if you start the schedule at 10:05 you would get the following:
Job1 10:05-10:07
Job2 10:06 - 10:08
Job3 10:07-10:09
etc…

Keep in mind that you can only queue one of each process on a bot so if Job1 is still running at 10:07 and Job2 is pending on that same robot then Job3 will not be queued.

Hi Daniel,
can you please share the work flow for a better understanding.

Hi @Abhilash_6057

Since the job is scheduled every one minute and the stop job may not be efficient. Reduce the job frequency to say every 5 minutes and the job should run at least 2 to 3 minutes to receive the stop job command. Otherwise it will not work. It is suitable for transaction-based processes.

For learning purposes, add a delay in your project and see what happens.

Thank you
VJ