Unable to Start Job from "Start Job" activity in Modern Folders

HI,
i am having issues starting a job from robot in a modern folder. The robots have all the permissions. I have even gave them full permissions at the user level and folder level.
I have a three level structure folders. Tried many times it keep getting the following error
Start Job: Operation returned an invalid status code 'BadRequest'
With these exceptions>

RemoteException wrapping Microsoft.Rest.HttpOperationException: Operation returned an invalid status code ‘BadRequest’
at UiPath.Core.Activities.TaskExtensions.ThrowIfNeeded(Task task,
Boolean suppresThrowException)
at UiPath.Core.Activities.Orchestrator.BaseOrchestratorClientActivity.ThrowIfNeeded(AsyncCodeActivityContext ctx,
Task task,
Boolean suppresThrowException)
at UiPath.Core.Activities.Orchestrator.BaseOrchestratorClientActivity.EndExecute(AsyncCodeActivityContext context,
IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context,
IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor,
BookmarkManager bookmarkManager)

This is my folder structure below. I am trying to start a job from the Compliance one. My folder path in my activity was "Users/External Users/Compliance". I have also tried following the instructions here Start Job on Moder Folder shows 'Conflict' Error but my issue still remains

@MARIODC you worked ion this. do you have any idea? Please and thanks

Hi @hatakora,

Thanks for reaching out to me.

Believe it or not that ‘BadRequest’ in my experience could be means different things such, no space between words, using capital first letter, not using copying the word/title as it is on Orchestrator.

Let me take a look then!

I see , sounds god. I spent hours trying variations of that with the spaces and all.

Hi @hatakora,

Let me show you how my ‘Star Job’ look like so you can compare and see if missing something, check img below:

Check the following :
–StartJob Activity–
•NumberOfRobots: 1
•ProcessName: use the process you are trying to call. In my case I call that job just before the current one ends.
•My FolderPath name is pretty much the same name by default in Orchestrator, I choose that to make it easier and leave it like that. Notice that it has no space in between

–Orchestrator–
•I only have one Modern Folder created
•You need to have a ‘Unattended’ Robot using that Folder
•Just in case I added all kind of Roles to the ‘Username’ which is only one in my Orchestrator

Hope it gets your activity to work, let me know!

BE Safe!

HI @MARIODC so i looked at that and tried it. The only difference is my folder structure. I have nested folders . But i have moved it to the parent folders and tried from there but the issue remains.

Check if your Process name is the -same- in both, Studio Activity and Orchestrator Display name.

Please notice that your package name could be different from the ‘Display Name’ in Orchestrator.

In my case I have the same name in Studio as my Display name in Orchestrator

image

So i just tried now again. In one folder that is as the same level as the default
See my settings in UiPath

See my settings in orchestrator


Everything seems fine in your end then!

I did a couple of test in my Studio, I removed the last character from ProcessName and FolderPath properties to see what would happened and in both cases doing it separately one at the time is when I got the message below:

image

By the way, how come you have less columns in your process tab?
I mean you can not see the package name which sometimes is helpful.

I have more:

I have no idea. Which verison are you running? I am on 2020.4.1

image

Community Version. Is your version Professional or something?

Yes. I am on enterprise version 2020.4.1

This is what I get if I force it removing a character from the FolderName

Same as you. ‘Bad request’ is too generic. It could be different reasons I guess then!

I know this is why i sometime hate this. They need to do better with the exceptions and error.

This is what I have in my Machine Template in my Modern Folder

image

Check/update your activity version as well…

image

Done already. The latest version. I have also tried downgrading. I don;'t think it is the activity. This works perfectly fine in Classic folders haha

1 Like

Not sure what else could be my friend, I hope you can make it work. I shared all my settings hoping could be useful!