Unable to start execution error for sample files on UiPath Academy

I get this error whenever I try to run sample exercise files downloaded from the UiPath Academy.

My files run perfectly. Have checked UiPath robot in services.msc - its is running.

Below is the error message

Could not connect to UiPath Robot Service. Make sure the service is started!

System.Exception: Could not connect to UiPath Robot Service. Make sure the service is started!
** at UiPath.Models.UiPathDuplexProxy.FaultTolerantProxy.g__CheckService|10_0()**
** at UiPath.Models.UiPathDuplexProxy.FaultTolerantProxy.CheckAvailability()**
** at UiPath.Models.UiPathDuplexProxy.FaultTolerantProxy.get_Channel()**
** at UiPath.Models.UiPathDuplexProxy.GetRobotConnectionStatus()**
** at UiPath.Studio.Plugin.Workflow.Services.RobotStudioBridge.Execute(WorkflowDocument document, Boolean isDebugging)**


Try to restart studio and machine once and then check.

Tried restarting both my system and studio - no luck, same error.


Which version are you installed ?
Have you installed it properly ?
If still not working then uninstall it and delete app data from UIpath folder and then try again.

HI @yusufht

You mentioned that the workflows you created are running perfectly and the one’s you downloaded from the academy are not due to the mentioned error…

Try adding the workflow downloaded from the academy to the solution you created to run workflows you create. You can use the Import workflow option to import the downloaded workflows to your working solution. Then, try running the workflow from your working solution… It should work for you…

Hi! I got this error because I had two versions of it in my system. Can you please check the version of UiPath you are working on and if there is any other version in your system?

1 Like

Yes, I had 2 version installed on my system. Removed the older one.

Current version is Community Studio Edition - 19.2.0, practice example files working now. Thanks.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.