Unable to start execution - 201903

studio
error
#1

Hi Guys,

I am facing the problem that the execution cannot be started no matter what scripts I am running. I can publish this script and run it from the robot. But the Run button in the studio is not working. I already tried to reinstall the studio v18.4/19.3, reboot the machine, reinstall .net framework, but still the same error. Anybody can help?

See error log as follows:

19:10:12.3727 => [ERROR] [UiPath.Studio.exe] [1] System.ServiceModel.FaultException1[System.ServiceModel.ExceptionDetail]: Cannot create and populate list type System.Collections.Generic.IReadOnlyCollection1[System.String]. Path ‘ReferencedAssemblies.$values’, line 1, position 309. (Fault Detail is equal to An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
Newtonsoft.Json.JsonSerializationException: Cannot create and populate list type System.Collections.Generic.IReadOnlyCollection`1[System.String]. Path ‘ReferencedAssemblies.$values’, line 1, position 309.
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateNewList(JsonReader reader, JsonArrayContract contract, Boolean& createdFromNonDefaultCreator)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateList(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, Object existingValue, String id)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.ReadMetadataProperties(JsonReader reader, Type& objectType, JsonContract& contract, JsonProperty member, JsonContainerContract containerContract, JsonProperty containerMember, Object existingValue, Object& newValue, String& id)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateObje…).

#2

Hi @Xin_Gao

Looks like you have some warnings, please clear all the errors before running the robot

#3

Hi Bro, you mean validate my script?
I did it but there is not any error in my script. Even I am just opening one browser like “www.google.com”, the same error msg poped up.

#4

Hi @Xin_Gao,
Is this a project that has been migrated from an older version to the newer one or is it a brand new project?

If you could send us the workflow, privately or publicly, that would be great, otherwise please send us the versions of the activity packages that you are using in the project together with details on the Studio version & machine.

Thanks,
Catalin