Unable to select table cell unless I scroll down to make it visible


I need to process through each records of a table result in this ERP application (JD Edwards). The application is accessed through browser ( i use Chrome). There are hundreds/thousands of record and as I process through records that are beyond the visible range, UiPath will return element not found. If i scroll the table to make the records, my UiPath code will work and I will be able to find the UiElement.

I tried putting focus on the table and it does not work as well. Is there a simpler way than to do other than scrolling?

Hi @Nickson

Please check ‘SimulateClick’ field in activity properties.

Thanks, Happy Automation.

Hi Vignesh, Just tried but does not detect still.

Hi Nickson,

We are also using Orcale JD Edwars as ERP tool in our organisation. we have developed multiple RPA processes there we are automating the processing of rows in JDE like for entering values in the cells we are using send hotkey - Tab and go to the next row we are sending hot key - Enter. i assume you are processing row by row in JDE right. using these shotkeys will resolve your error i guess. Any help needed in the JDE automation please let me know. thanks.

Kiran, appreciate your advise! However, my issue is different. After inquiring sales order list of a customer, I i am trying to download the attachment from each Sales Order line. So some lines have attachment , some not and attachment field cannot be filtered. So, my method is process each row but I hit the issue where UiPath cannot “see” the row until i scroll down the table as I process through each record. Even if i try to scroll down using Page Down and make the row visible, the result bounce back to the top row after the attachment retrieval. This makes it complex to code and slow as well.