Unable to select Remote Desktop Connection with Open Application

I am unable to use Studio to select, open or use the Remote Desktop Connection application in Windows. I need to start the process by opening up RDC, remoting into a server, performing actions in that server, then disconnecting from the server.
I have tried to use the “Open Application” functionality, as well as Recording both Basic and Desktop, but whenever I click on the RDC application, it never registers:



I can manually fill out the File Name property with the full path to the RDC application (C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Accessories\mstsc.exe) but I still need a selector, and not sure what to do there.

Thank you for any assistance.

Hope these steps would help you resolve this
—use a SEND HOT KEY where use a key win+r
Where choose win key and enter as r in the key (though its not there in drop down it’s fine)
—now use a TYPE INTO activity and choose that Run window field as element or even without selecting any element and type the input string “mstsc”+”[k(enter)]”
And ensure that sendwindowmessage property is enabled and simulate type property is disabled in the property panel of type into activity
—followed by that the RDC window will be opened
Then Use GET ACTIVE WINDOW activity where inside that use TYPE INTO ACTIVITY and enter the server as string and then a send hot key with tab as key
Followed by that use a type into with password and send hot key with enter as key

Cheers @MickBisson

This is tough to debug without taking a look into your machine. I tried on mine and that seems to work.

Give this a try :
Once you start recording using Desktop Recording, Try clicking Start App and click on the remote desktop connection window. Then try continuing with recording the steps.


Thank you for the responses. I have tried both of your methods and still come up with a blank recording whenever i try to start or interact with the RDC application.

I thought to try this operation directly from our Test server instead of on my local machine and I was able to interact with the RDC application without any issue. It looks like this might be a security or permissions issue with my local machine. I will reach out and try to resolve going on that assumption.

Thank you again for the assistance!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.