Unable to search items from queue in a browser in subsequent iterations

Here is my requirement.

Objective- Take a value from QUEUE and search on a website for more additional details and extract the required details and store in the file.
Now the issue is - For the first item, the desired objective is achieved.
when the process picks the second item - it is typed into the search bar. But at the same time, it is erased. Eventually, my logic is extracting the results of the first item always. Kindly help

You should probably call Ghost Busters! :joy:
JK - I don’t really understand what’s happening there. Could you elaborate?

Maybe try it in a different browser or use the “Navigate To”-Activity instead of typing your URL.

Cheers, Lukas

Be my Ghost buster !!! :rofl:
Please find the attached for more clarity.

This is my Queue –


Item1 – IBM, Item2 - AAPL
I am taking Item_1 and searching for share quote – and storing the values in IBM folder.
Below is the result
Opened browser –


Till here this is fine. It does what it has to.

  1. Item_2
    The value types into the search bar by the process but looks to me it cleared the search bar and upon hitting enter the first item result is refreshed. which eventually not retrieving the result of second quote.

Second Item log -
“message”: “Type Into ‘INPUT yfin-usr-qry’ Executing”,
“level”: “Trace”,
“logType”: “Default”,
“timeStamp”: “23:41:18”,
“processVersion”: “1.0.0”,
“jobId”: “33b1b64d-9eb7-42bd-a154-1f14cb0342f5”,
“robotName”: “Firstrobot”,
“machineId”: 215129,
“fileName”: “Process”,
“logF_BusinessProcessName”: “Framework”,
“activityInfo”: {
“Activity”: “UiPath.Core.Activities.TypeInto”,
“DisplayName”: “Type Into ‘INPUT yfin-usr-qry’”,
“State”: “Executing”,
“Variables”: {
“CompanyFullName”: “”,
“Shareval”: “”
“Arguments”: {
“Target_TimeoutMS”: “30000”,
“Selector”: “”,
“DelayMS”: “300”,
“ContinueOnError”: “False”,
“WaitForReady”: “INTERACTIVE”,
“Text”: “APPL[k(enter)]”,
“ClickBeforeTyping”: “False”,
“DelayBetweenKeys”: “10”,
“Activate”: “True”,
“DelayBefore”: “200”,
“SimulateType”: “False”,
“SendWindowMessages”: “False”,
“EmptyField”: “False”

The URL seems to be built the same way everytime. You can try building the URL dynamically depending on your Queue Item and then use Navigate To Activity instead of typing the URL in the search bar :wink:

That should be an alternative. But then there is no point in using search bar provided. What do you suggest?

Well, the search bar didn’t work properly it seems. Upon closer inspection the URL has changed in your screenshots, but you didn’t get to AAPL’s quote page. You can try clicking the search button instead of hitting enter, otherwise I can still recommend using the Navigate To activity :slight_smile:

1 Like

Yes you are right, AAPL is typed but not able to navigate. I will try again using click. Thanks for your help

1 Like

The click search button worked. Still no clue why the hitting enter key by bot didn’t work. Thanks for your advise.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.