Unable to scrape data from Citrix using CVGetText of Computer Vision(CV), the text field here is uneditable, used all the engines, still unable to extract the field?

Hi Guys,

I am trying to extract data from Citrix client application using CVGetText, however unable to get the correct data, how can we extract the data from application

1 Like

Hi @mohd,
If application by itself is compatible with Studio (in terms of UiElements) you could use native Citrix support. This requires to have runtime installed on XenApp workers and Citrix extension on machine with Studio.

Hi Pablito,

Thanks for the reply. We have a limitation here not to use native Citrix due to performance, the architecture is defined in that way. Only option we have here is Computer Vision(CV).As per my knowledge, UiPath mentioned that using CV we would be able to identify all the Citrix elements, so here CV is the only option.
Do you think that would we be able to get positive outcome here using CV?

Yes CV should also do the thing but you need to remind that CV activities are working with use of AI. Based on that your robot need to have constant internet connection so AI will learn and know what to do. I’m mentioning it because I used to work much with Citrix and I know that many environments are completely disconnected from network and only way how users are connecting to XenApp is StoreFront + NetScaler.

Hi @mohd

Have you tried using Ctrl+ A send hot key and Ctrl+c activity and use copy selected text and store it in a string variable


More details pls? Does it get the wrong data or no data?

Also, check latest version, might have better results. It also has a new option in GetText called “use clipboard” that doesn’t use OCR

What is the status of this? We have been having a lot of issues accessing data reliably with CV. We are running Citrix, but do not have access to the backend to install a runtime. CV Get Text simply does not recognize the majority of the text in the application. Any tips?

Have you tried to experiment with other OCR engines, changing attributes etc?