Unable to scrap complete Data table from web application

datascraping

#1

Unable to scrap complete Data table from web application,

I am able to scrap the first column of the table but the second, third and fourth column are not scraping.
I tried to use the selectors to check any difference but not able to find any difference in selectors.
Every time I am trying to scrap table only first column data is extracted.

Please suggest…


#2

Hello Gajanan,
Please share the XAML file for us to understand this better.

I suggest you follow the steps mentioned in this article if you haven’t already:


#3

Yes…i have already done all these steps, but still unable to get data for 2nd,3rd, and 4th column.
As in my case I am trying to extract the data from web application, which has 4 columns, like

T_No T_Date T_Type T_Status

I am able to get data from first columns only for rest of columns it is blank only…


#4

Share your worflow file (XAML) so that we understand what has been missed and suggest changes.


#5

The work flow is same as you know for normal scraping…due to system constrains I will not be able to share the XML file…
I understand it is very difficult to solve the issue without seen the screen or table…

Thank you for your help…


#6

@Gajanans22 Have you tried with another table? Just to see if it’s the same behavior.


#7

Yes I tried with another table, for that table scraping is working …


#8

Maybe there are actually more

attributes in that HTML. (I guess you’re doing a direct HTML table scraping).
Instead try to work with pattern based extraction (indicate the fields from 2 consecutive rows)