Unable to save(Download) file

Hi Team, I am trying to Save(Download) a Zip file from a website, Clicking on Zip file is working fine but when I get the pop up to SAVE file, Click activity and Send hotkey are not working. I am attaching the screenshot of the correspondence page.
Note:: When I keep this page open, Click and send hot key work while running the .xaml file.


are you able to scrape the elements when you are popup to save file?


1 Like

@Srini84 No bro, scraping method is not working for this.

Hi @Rajnish,

you can disable this pop up if it is problematic like this and if it is usable in your scenario:

Disable the File Download Prompt

  1. Open an Internet Explorer browser and click the gear icon to open Tools . (You can also press Alt + x to open Tools.) Then click Internet Options > Security tab.
  2. Click the Custom level button to open the Security Settings.
  3. Scroll down to the Downloads heading and select Disable for automatic prompting, file downloads, and font downloads.
  4. Click OK , and when asked if you are sure, click Yes .
  5. Click OK again.
  6. Close all Internet Explorer windows, and then re-open Internet Explorer and attempt the download again.

Also you can try to use click Click Image activity:

HI @Rajnish,

  • Get the hyperlink of the fiile.
  • User the File download activity from here.

Video :


@dfilipovic Thank you for your response, When I use above steps, It blocks the download of Zip file throwing an message “Your current security settings do not allow this file to be downloaded”
Click image is also not working

1 Like

@Rajnish sorry it didn’t help…
I have found someone with similar problem as you on a forum:

He has solved it by pressing the arrow near ‘Save’ button then pressing F2 but you can check the solution out on the link that I am posting.


1 Like

Hi @Rajnish if this solved your problem can you mark this as a solution so I get some points. :slight_smile:

1 Like

@dfilipovic Sure, let me try these steps.

@dfilipovic it only works when a page with saving option already opened, otherwise it doesn’t work.

1 Like