Unable to save as ".pdf"

pdf conversion


Here I am trying to save the file in a folder whose path is taken from Config, I want to save the file as PDF after the full name of the user and send mail.

I tried running the Performer it’s unable to save the file in “.pdf” format, and it’s not sending the mails either
names without

As we do see the PDF File type association we assume the following:

  • known extension is not shown

File Explorer
click on Filetype extension:

we would ask for more details on what was implemented

Sorry I am not getting you. Please tell me what information you need?

Hi @Anirudh_Tugawe

Check that str_FullName contains the desired file name without any invalid characters for a file name (e.g., \ / : * ? " < > |).

Put a Log Message in before the PDF activity, and output the value of the path and filename same as you have above in your screenshot. Then you can see what it’s trying to save.

When you say “It’s unable to save the file” what does that mean? Are you getting an error message? The file is saved but has the wrong name? You have to give details.

Same for “not sending the mails” - why not? Error message?

Yes it is saving the file at given desired location and there’s no error in this process but still it suppose to save the file with “.pdf” at the end which is not happening.

no it doesn’t contain any special character

It is saving it with .pdf on the end (that’s why the files have a PDF icon and file type), you just have Windows Explorer set not to show extensions.

In Windows Explorer, with that folder open, check the “File name extensions” box on the View menu:

As mentioned above within the first answer

And also

1 Like

Thankyou so much sir, even @ppr tried to tell me the same thing , anyways thankyou bot of you.

now I will check the performer run.

I did that extensions enabled in the file explorer but now its throwing the error of Application exception #1856

And what is the exception?

Well, it was a silly mistake made by me, in the SMTP activity I have my email ID manually and in the user name and password I used assets of my other Email ID, even though the port value was wrong this error was thrown.

Thank you so much

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.