Unable to RUN UiRobot from command line which deals with excel files. Any Help?

excel
robot
robotservice

#1

“C:\Users\ZeeshanAmanat\AppData\Local\UiPath\app-18.2.1\UiRobot.exe” /file:“D:\Automation\UiPath\Main.xaml”

It runs other processes perfectly but unable to run the process with Excel files.

Any help appreciated.
Thanks!


#2

Can you please elaborate? What exactly happens when you try to run a process dealing with excel files? Does it throw any error?

Thanks,?
Rammohan B.


#3

Hi Rammohan, Here it is the error I got on running the process having Excel activities.


#4

I believe it occurs when you don’t have that particular package installed.

Are you able to run it from UiPath Studio?

Thanks,
Rammohan B.


#5

Yes, It’s working perfectly from a studio. I am using Studio 2018.2.2 Community Edition.


#6

Your robot here seems to be pointing to 18.2.1. Can you try changing this to 18.2.2 as well?

Thanks,
Rammohan B.


#7

Tried both versions. Same error while trying to run from UiRobot.exe via Command Line.

We’re really stuck to deliver this to a client and this problem has started to show up just recently, the same command line was working perfectly fine with the earlier version 2018.2.0.