Unable to run Flow in 2019.1 version

Hi,
i am trying to run just single write line activity in flow but its giving following error:

"19.1.0+Branch.master.Sha.3db2bfe8751ed76c2c21f7ee16f53ff69a3e3b75

The message with Action ‘http://tempuri.org/IUiPathRemoteDuplexContract/SubscribeToEvents’ cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher. This may be because of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch between the sender and the receiver. Check that sender and receiver have the same contract and the same binding (including security requirements, e.g. Message, Transport, None).

System.ServiceModel.ActionNotSupportedException: The message with Action ‘http://tempuri.org/IUiPathRemoteDuplexContract/SubscribeToEvents’ cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher. This may be because of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch between the sender and the receiver. Check that sender and receiver have the same contract and the same binding (including security requirements, e.g. Message, Transport, None).

Server stack trace:
at System.ServiceModel.Channels.ServiceChannel.ThrowIfFaultUnderstood(Message reply, MessageFault fault, String action, MessageVersion version, FaultConverter faultConverter)
at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object ins, Object outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at UiPath.Models.IUiPathRemoteDuplexContract.SubscribeToEvents(ServiceEventsFilter filter)
at UiPath.Models.UiPathDuplexProxy.StartJob(JobModel job, Nullable`1 eventSubscription, String password)
at UiPath.Studio.Plugin.Workflow.Services.RobotStudioBridge.Execute(WorkflowDocument document, Boolean isDebugging)"

Thanks,
Bhushan

please restart your UiRobot.

thanks its working now:)

I couldn’t find UiRobot and I am still stuck with this. Any other way that any one of you know?

please search UiPath Robot is installed in your machine or not?

Uipath robot is present and it is connected as well. As per the replies above reply I checked the UiRobot in the services and couldn’t find any. Also, I also arbitrarily disconnected the UiPath robot.

Please exit from UiPath robot and try to open again.

There was risk of getting stuck on this for long. Thanks for staying and prompt response :slight_smile:

I have restarted uipath studio and uipath robot, still no luck…
Any other suggestions.

Hi @Chaitra_Pc

Please refer to this post:

Thanks @loginerror. Restart of machine and reinstallation worked

1 Like