Unable to run a process after creating a modern folder (with option 'Create a package feed for this folder' )

Hey Guys,

In 2020.10, we created modern folder by enabling option ‘Create a new package feed for this folder’.
Post this, when we try to run a process, it is giving error as:
'Unable to install package ’

however, when we create modern folders by enabling option ‘Tenant package feed’, everything is fine and we are able to run the same process.

Looks like, packages are not being identified at folder level.

Has anyone else also faced this issue?

Hi @sonaliaggarwal47,
Welcome to the Community!
Creating package feed means that this folder will work only on packages defined by you for this folder. As you are not configuring any package feed it can’t run you automation as there is no feed from which it could grab dependencies.

More information:

Hi Pawel,

Thank you for your response.

After creating a modern folder, I had also uploaded packages at folder level.
Post which I created a process by selecting the packages which have been uploaded at folder level.
Process was successfully created.
But when I try to run that process, it throws error 'Unable to install package '.
However, I am able to explore package uploaded here which also confirms package is uploaded successfully at folder level.

Now if do this whole process for modern folder but by enabling tenant level feed and then try to run a process, I am successfully able to do so.

1 Like

Hey Guys,

Adding a complete error message we are receiving while trying to run a process:

Failed to install package ‘PACKAGE_NAME’

RemoteException wrapping System.Exception: Failed to install package ‘PACKAGE_NAME’ —> RemoteException wrapping System.Exception: NU1101: Unable to find package PROCESS_NAME. No packages exist with this id in source(s): Go!, https://…ca/…/index.json, https://…ca/…/index.json, Local, nuget.org, Official

Please suggest if anyone has come across such issue.

1 Like

I faced the same issue. Have You solved it? Moreover there are published project packages in the feed https://…ca/…/index.json

Hey @sonaliaggarwal47 , @user42 ,

Was facing the same issue and the below approach helped resolve the error.

As per my understanding, the error is caused since the robot does not have sufficient rights to view and install the Folder Packages.
By Default, the Robot role does not have the permissions to View/Edit/Create/Delete the Folder Packages.

  • If your unattended/attended bot is assigned the Robot role, navigate to the Roles menu under Tenant and provide the View permission.

  • Disconnect and Reconnect the machine to Orchestrator (May or May not be required)

You can try if this approach works for you too.

More details about editing Roles:

2 Likes

Thank you @manishjagtap for your inputs.

Yes we had tried doing that as well but it was working inconsistently.

Later on, we figured out it was happening due to presence of classic as well modern folders(with difference being in the way user cred are recognized) in our orchestrator. When we created a new tenant with all modern folders in tenant, never faced the same issue again.

Alternatively, it works if we use Personal workspace in orchestrator in case orchestrator has both classic/modern folders.

@user42 Hope, any of these approaches and the ones stated by @manishjagtap helps you.

Regards
Sonali

1 Like