Unable to recognise UI Elements in chrome

issue

#1

Hi All,

UiPath is unable to recognize elements with chrome. It use to recognize earlier but from last one week UiPath is unable to achieve that. It responds really slow with chrome. selects the complete screen as a ui elements and when i chick throws an error “Invalid UI Node”.

I have a whole workflow written in chrome and now nothing works except open browser.

Things i have tried:

  1. Removed extension then reinstalled
  2. disabled then enabled extension
  3. zoom of chrome is set to 100%
  4. removed dotnet framework, installed the latest 4.7
  5. removed uipath, reinstalled
  6. checked with firefox and IE works fine, except with few UI components
  7. Checked all the steps mentioned in https://studio.uipath.com/docs/chrome-extension, everything is in place as expected

Please let me know if UiPath should be used any further or not. Or is this going to behave sporadically all the time and the developers are forced to work with such an unstable tool or rather opt for a better option.

Thanks!


#2

UiPath is the most stable tool compared to any other automation tool. I have faced this problem in the past and got resolved post re installation of extension, which you have already done. The only option left is to format the machine. If you have one more machine, can you try once in that machine & make sure there is no problem with UiPath. Which version of Windows & Chrome you are using ? Can you upgrade Windows or Chrome ?


#3

We have four developers working on UiPath. Each one of us has experienced sporadic behavior, mine being the worst hence the post.
Why do you think a system format would help? What exactly has went wrong? Can you please elaborate?
I have the latest chrome build Version 68.0.3440.106 (Official Build) (64-bit) on windows 7. None of them can be upgraded.


#4

@ClaytonM, @aksh1yadav, @vvaidya, @ddpatil any leads here?


#5

strange, same issue on all machines ? Not able to guess the root cause…only UiPath support team can help.


#6

Hi @ayeshakhan ,

image

Try to change Chrome Extension and try again.

Refer the link below
https://studio.uipathcom/docs/installing-the-chrome-extension

Regards,
Arivu


#7

Is there any possibility that the latest Chrome broke the plugin? Chrome Version 68.0.3440.106 was released on August 8, which would correspond to when your issue started.
Just a thought.


#8

@arivu96 This link isnt working for me. And i have reinstalled the extension as you have stated


#9

@loginerror That might be the case. But my other team members also have the latest version but things working fine for them. What should i do if the chrome upgrade is the problem? Should i downgrade?


#10

Maybe a simple cache cleanup or reset to default would work for Chrome?
How about trying it out first in incognito mode (I think you can enable an extension in incognito mode on extension page).

If it works for your colleagues on the exact same build, then it is not an issue of the plugin (or it is highly unlikely).


#11

Tried setting everything to default. Not working in incognito as well.


#12

Getting error:
image


#13

This one, believe it or not, is often resolved by restarting your PC.

Also, last three posts of this topic might give us some clue:


#14

It might be helpful to know like where the errors occur in your workflow or what sporadic behavior there is and if the behavior can be identified to specific activities, et cetera.

That error you are showing can happen sometimes if you are using a Windows variable in an Attach Window. If that is the case, I think UiPath is aware of the issue. The workaround was to use a selector string instead. What usually happens when you get the error is it tries to click something inside the attach window, but it throws that error.

I don’t know if that will help, but hope it does.

Regards.


#15

Thank you so much! That was a great help!!

Its working fine now :slight_smile:


#16

Not working again… :frowning: