Unable to Read PDf Files due o pdf viewer

Hi Everyone,

I am reading all the pdf files in a folder. The first pdf file get successful but while reading the second pdf files and so on I am getting a error -" The full content of this file cannot be displayed with your current pdf viewer . Please update to the latest posssible version to view this document".

But uipathis able to read the first pdf , why I am getting this error while reading the other pdfs also I can open and read all these pdf manually in Adobe.

Hello @Karan28 ,

Are you using Read PDf Text activity?
Or you’re opening each file from folder and scrape the tex from it?

Can you provide a screenshot?

Vasile.

YEs I am using read pdf text activity for this .

Can you just try to change the version of activity or can u check with other file other than u are checking (2nd file). If the file is corrupted it might throw this error.

I have 4 pdf files and Read pdf text activity is reading only the first pdf. not the other pdfs. I dont thing there is some issue with the other pdfs

can you change the version of activity, can u attach the pdf so that I can check if not confidential

SR_0000133848.pdf (151.3 KB) SR_0000136218 - CONTRACTREVIEW.pdf (1.0 MB) SR_0000136247 - CONTRACTREVIEW.pdf (1.1 MB) [SR_0000136253 - CONTRACTREVIEW.pdf|attachment]
(upload://dFARUI3ZaPBOhR8zn1BuPPlVwIE.pdf) (1.0 MB)

Here UiPath is able to read the first attached pdf only not the other ones. Also I ahve check the pdf activity package version , it is up to date

@Karan28 your first pdf file is non editable pdf but your second pdf file is editable. I think you need to go for document understanding for this type of file. Is your Adobe is lic?

FYR

Okay , is there any other way?

Hello @Karan28 ,

I did a quick test and if you reprint the PDF file (Print to PDF), the printed one works OK, UiPath can read it.

Not sure if this is feasible for you, but is a good workaround.

(I have Acrobat PRO, tried to export that file in xml, txt, rich text, for all of them same issue)

I hope it helps.

Vasile.

Yes I saved the input files again using print and it worked now.
Thankyou so much for the solution

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.