Unable to read gmail inbox content using GET IMAP mail messages

@Anders_Kink Hey! I tried all this stuffs but it doesn’t work for me any solution please? Thanks :slight_smile:


Can you link your code maybe some errors there ? :slight_smile:

Here is the flow Mail_Trigger_Sample (1) (1).xaml (23.0 KB)

Seems correct. The error you are getting, can you post?

This is the erro
“Get IMAP mail messages : A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond xx.xx.xx.xx:993

sorry for my late answer, the problem is google have change the way you access it in here: https://myaccount.google.com/lesssecureapps

You now have to create an app password.
Link above go to -> Security -> Login to Google -> app password
Here you generate an key to use as password.

Hope it works :slight_smile:

Hi Jay,
Instead of your own gmail password in IMAP try with the get credentials activity in uipath. some thing like that. Have you tried this? and use two step verification.


1 Like

I tried all solutions on the forum for this problem but what worked for me is just switching to another network.

You only have to do two settings

  1. enable IMAP for Gmail account
  2. turn ON less secure app access for Gmail account

Use port 993 in the activity.

and if you are able to receive emails on the web (manually checking Gmail account) it does mean that port is open by default.

Mohini Nemade

1 Like

is it possible to do Filtering of subjects/sender in get Imap mail message acitvity??

@mohininemade301094 Thanks for your solution.
I tried a lot of different ways to solve my problem with mail activities on UiPath, all unsuccessful. Changing network from office network to mobile hotspot worked!!
After few hours of trying of different activities and settings in UiPath, almost run out of coffee, found this post :slight_smile: thx again!

1 Like

This solution works perfectly on port 993.

Hi All,

I have tried all steps but still i am getting same error
Please help on this issue.


How can i do this in Outlook email??

Hi Jay
change your gmail security setting as less secure app acesses should be on
i think this might work

Hi Ritesh, did you get to do this with outlook? Please help to share the solution.

Thanks for your advice. Works for me.