Unable to read a script type error popup and cannot be read as an element by UiPath

Hi All,

I am trying to capture a script type error message but UiPath studio is unable to capture it. I tried Element Exists and Find Element but with no avail. Can you please suggest what should be the approach to tackle this issue.

Thanks in advance.

Abhishek Deb.

The problem will probably not be in activities, but in used selector. Can you attach screenshot of UiExplorer with captured dialog?

The issue is I am unable to locate the error message in the selector box as shown below. I checked one of the forum information but does not apply in my case I suppose.

Is the problem, that you cannot capture the dialogue content, so you cannot get its selector?
If so, you can try to find dialogue in element tree manually.

You maybe right let me try to add the dialogTitleContainer and see if that works. The dialog that I am looking for is not present in the tree though.

I tried adding the dialogTitleContainer to the selector and it did not work. It seems that it is picking up the Store to “Invoice” value in the background and not the error message. I believe it is because the error message is a script type error and not a popup physical error message box.

Did you try to change capturing methods (by F4 during indicating element)?

Do you mean by pausing the capture event?

Try to switch to AA or UIA by F4.

Can you please guide me the steps I am a noob here :slight_smile:

Tried changing it to AA or UIA while selecting did not work :frowning: Shall I try Image exists, will it work?