Unable to Publish the project

Hi Team,

iam unable to publish my project, whenver i click Publish button, i get error 405.

dont know where the problem is, the individual .xaml files work in Studio but when i try to publish it, it gives 405 error (Method not allowed). Iam using the right orchestrator link

Greetings @bjohn , Welcome to UiPath Community!

Can you please check the file size? I think after taking the sreenshots by the BOT the file size became bigger and thats why its happening. Its just a thought. Please check the file size of that project. If thats bigger then you might have to delete the screen shots taken by the BOT.

Happy Automation!

Hi @bjohn

Is there a chance that it works well now? (could have been a small performance hiccup of the Orchestrator).

Also, a simple machine restart, just in case some robot service has not restarted properly after auto-update (assuming you are using Studio Community edition).

Sorry the File size is small still getting the same error.

No Still have the issue, restarted multiple times still same issue.

Yes iam using the community edition

@bjohn
Are you tryting to publish straight to Orchestrator from your Studio or are you publishing locally and then upload it manually to Orchestrator.

Can you try both methods?

@jvanmarion i tried both methods, both giving the same error 405.

I have even deleted the Tenent from Orchestrator multiple times and set new tenant still getting the same error. My assistant is connected.

as iam unable to publish iam unable to create a process in Orchestrator

getting this error

“1:41:15.9597 => [WARN] [UiPath.Studio] [59] No API Key was provided and no API Key could be found for ‘https://cloud.uipath.com/duca/FirstTest/orchestrator_/’. To save an API Key for a source use the ‘setApiKey’ command.”

@bjohn
Uploading manually of your package should not result in a 405 error.

  1. how did you setup your tenant? (did you add the licenses to it?)
  2. Did you add your machine to the Tenant?
  3. Did you add a robot to your Folder and selected the machine?
  4. Which type did you use for the license of the robot?

There are several methods of publishing your package to Orchestrator. But make sure that the conditions are set correct!.

1. Publish locally.
Disconnect Uipath Assistant.
Start UiPath Studio. Open a project and click on publish
Check your Publish settings. “Assistant (Robot Defaults)” should be selected
UiPath.Studio_61gy25S8kp

This will publish your package in C:\ProgramData\UiPath\Packages
Then upload it manually to Orchestrator in https://cloud.uipath.com/TENANT/TENANT/orchestrator_/packages

2. Publish straight to Orchestrator.
Add your Studio machine as a machine to your Tenant.
Connect UiPath Assistant to Orchestrator based on the Machine key

This is not enough to being able to publish to Orchestrator. Because if you want to publish to orchestrator it will result in a 405 error.

You have to add a Robot for it.
For example i have a Classic Folder “Homelab”
In that folder i can add a Robot. So i called it DRAGON as you can see. Set the type to "Attended (RPA Developer Pro).


Reconnect your Uipath Assistant. It should be Connected and licensed and in your orchestrator it should be online in your Folder > Robots

Now open Studio again (close it when you had it still open). Open your project and click on the Publish button.
Now when you want to publish you can see a new setting as default: “Orchestrator Tenant Process Feed”. By default it should be set to that selection.
UiPath.Studio_QQzB34VayE

So now when you publish it will be published to Orchestrator. UiPath.Studio_tNZHv3XM0s

Lets check in Orchestrator on Tenant level in packages


And there it is. You can check the detail info to see if it is the correct version of the package.

I hope this will help you a bit.
also check this page: About Publishing Automation Projects.

The only reason for using a custom Url is when i publish my package to a Nexus3 server. That is where i use the ApiKey for. I never used the ApiKey from Orchestrator.

Summary:

But i think the 2nd option would apply to you.
Option 1 is most of the time used when a direct connection to Orchestator is not allowed or possible.
Option 2 gives more freedom and speed for deployments
Option 3 you will use when you use your own repository server (for example Nexus), so you don’t want orchestrator to be your primairy package server.

At others. If there are better options in the meantime feel free to correct me. I don’t use uiPath on a daily bases, so this is to the best of my knowledge

Thanks @jvanmarion the publish option works now.
have another issue
When i try to run the process through orchestrator, the Job always says pending and it sits there for ever, does not error. I think the set up is not fully done.

i have deleted Tenet multiple times but still the job is not executing from orchestrator, dont know if i have not set Robot correctly.

Can you please guide me

Glad it worked for you. Please mark the answer as a solution your problem.

The pending process is another issue.
PS: why are you deleting your Tenant every time? It has nothing to do with the error. And every time you have to set it up again. In the 2 -3 years im running the cloud version i have never even deleted my tenant.

Pending process can mean a couple of things.

  • Is your robot capable of downloading the packages from Orchestrator. The first time it will check if the robot has the packages locally installed. If not it will get the packages from Orchestrator. If that is not an option it will get the packages from the nuget stores. If that is not working, your proces will error.

  • So make sure the robot has all the applications installed you are using in your process. (browsers, excel installed for example)

  • Start with a simple script to test your robot. Open a browser, write some text logging or create a folder, something like that. After that you can make more difficult processes.

  • Does your robot has a shadow function enabled? (so you can monitor your robot from another machine), so you can actually see what the robot is doing.

  • Eventually it should timeout.

  • Check the robot logs on the machine itself if you can find errors.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.