Unable to publish because of NU1101

Unable to publish because of this issue. I don’t want that package.

If you have it mentioned in any of the custom libraries or your project in project.json file, it is still required.

So, check if is still required or not, and in case if not, just remove it from the project.json and publish a new version of that library and update that library version in your process.

The easiest way, will be to upload that missing library in your Orchestrator tenant libraries feed.

I don’t have that library anymore.

Do you have a robot that run that process with that library?

If yes, you will find that library nupkg in %userprofile%\.nuget\packages\library_name\library_version

If that library is not required and you don’t need it, just remove it from the project.json and publish a new version of that library and update that library version in your process.

If the above is not an option, recreate it, publish to Orchestrator and specify it in your project.

Can you share a screenshot lf location. It will be pf great help thanks

In the robot that run in the past that process, it should have that library nupkg file under %userprofile%\.nuget\packages\library_name\library_version:

Example:

1 Like

I figured it out it was a dependency caused by another library