Unable to process records in ReFramework

ReFrameWork-master.zip (1.7 MB)

I am working on ReFramework and while running my process my bot opens acmetest…extracts the structured data and closes the acmetest website.
Post that it re-opens th acmetest website,reads the tabular data again, opens sha1-online and kills the process.

i have attached my assignment.can you please check and support where i am going wrong.
Below is the error it throws in output panel.

image.png992×258 8.38 KB

Hi @somya177,
Please check your Process.xaml. Most of problems like this are effect of not processing arguments from one invoked workflow to another. Then part of your process is not having necessary data and REFramework is catching this as an exception and starting everything from scratch.

1 Like

Hi @Pablito
I checked multiple times but still I am unable to fix the issue.
Can you please do the code review and let me know where I am wrong.

Let’s start from first thing I have found. As I said in my first post please check arguments in your Process.xaml.
Here’s what I have found in very first invoke:


this problem I am facing…i give values to invoked workflow but when I re-open the import arguments they get vanished

It’s not a bug or problem. If you will import the arguments once you shouldn’t click “OK” button when if you will click Import Arguments again. To check the arguments you can use Properties pane:

I fixed the first thing…now the arguments are:

checked rest other invoked also…they are having arguments along with variables…but still while runnin the process, its not opening client details web page after extracting the datatable.

still I got this error:

Please click twice this error and show me the whole window of this error.

“message”: “Error getting transaction data for Transaction Number: 0. Value cannot be null.\r\nParameter name: source at Source: If a new Item is fetched Grab it’s significant data for logging”,
“level”: “Fatal”,
“logType”: “User”,
“timeStamp”: “17:02:59”,
“processVersion”: “”,
“jobId”: “e15d113e-6a58-404d-8ecd-6a2c4c7baf9c”,
“robotName”: “mea\somya.parashar”,
“machineId”: 150646,
“fileName”: “Main”,
“logF_BusinessProcessName”: “Framework”

Please check here for your arguments for this xaml:

i checked…but I am unable to figure out what is wrong
@ddpadil can u help?

@c.ciprian can u also please look into it…

I meant that you should check this invoke as you have completely empty arguments and not all of them. Here is your invoke:

Here is how it should like according to the instruction:

How REFramework can pass any data if you are not putting them in Transaction? Please check instruction and correct bugs like this. And please check every argument and remember to do not click “OK” button if arguments are fine because by clicking OK you will make them empty.

I did the amendment but still I faced the same issue.
It first opened acmewebsite…extracted the datatable and logout.
Post that it again opened acme website…reached till click workitems but it didn’t click on workitems…instead opens sha1-online and post that it threw the same error.

Expected: In the first instance after opening acme test website and extracting the datatable it should navigate to webpage to extract client details of type WI5 but it logged out of webpage after extracting datable till the end.

Have you tried debugging to check at which step it fails?

yes…I have shared screenshot as well…in the if condition of get transaction data

Seems that you have wrong assignment to your out_TransactionItem. It should be:
If I good remember in instruction there was mention about it that you need to be careful about indexing).