Unable to perform web-recording for chrome as it pop ups an error message "Error HRESULT E_FAIL has returned from a call to COM component"

Scenario: When we perform webrecording for chrome an error message is displayed

Steps to reproduce: just open chrome and try to perform web recording

Current Behavior: Web recording works fine while using IE or Firefox.

Hope you have already installed UiPath extension in Chrome, Try to uninstall Uipath extension and re-install.


Please follow up this.

1 Like

hi Dilip,
I am also facing the same issue “HRESULT E_FAIL has been returned from a call to a COM component”
I tried all Chrome Extension Troubleshooting options but nothing is working for me.
un installed and re installed chrome browser not luck. removed extension several times and re installed still same issue.
UiPath not recognizing the chrome objects. same script is working fine in different machine but only 1 machine has some issue. No idea what might be the cause. installed DotNet 4.5 SDK also but same problem.

Could you please advice if any alternate to resolve this issue.
Thanks in advance.

I believe you tried chrome troubleshooting and if still persisting then give a try with IE.
How about this one.

i have no choice… i have to use Chrome only because my module will save the browser content into PDF.
Tried that link too but no luck

try with .net framework 4.6

Finally, when i add Microsoft .Net Framework 4.5.1 Multi- Targeting Pack resolved my issue.

1 Like