Unable to Perform 'Type into ' Activity at Oracle Application

activities
p_qa

#1

Scenario: data to be entered in a text box exists under oracle app

Steps to reproduce: run automation workflow

Current Behavior: unable to see the enter characters

Expected Behavior: entered data should be visible

Studio/Robot/Orchestrator Version: studio 2016.2

Last stable behavior:studio 2016.2
Last stable version:studio 2016.2
OS Version: windows 10
Others if Relevant: (workflow, logs, .net version, service pack, etc):


Element Exist always return true for Java Oracle forms on Windows 10 OS. Did anybody else face this issue?
#2

Hi @mayurika
Does it work when you enter the data manually? And what type of data are you trying to input?(ex: special chars, japanese/other language characters?)
Also, could you give me the selector of the text box?


#3

Hi,
I am trying to automate Oracle application and I am unable to perform “type into” activity. I do have multiple pop-up open and its the requirements for the project. While automating, Oracle doesn’t let me close other pop-ups and leave one open that’s being automated… UiPath doesn’t recognize the new pop-ups. I am unable to choose a box for type into for new pop-ups.
Please let me know what is the work around for this situation.

Thank You !


#4

Have you figured your problem out? Could you tell me what kind of Oracle app you are automating? Are you trying to type into an EBS form or a web page? Any other details you think might be helpful.


#5

It hasn’t worked. I am using Oracle Non Prod environment for the reporting purpose. I am trying to type into a web page in order to schedule /download and run reports.
Please let me know if you have questions.


#6

couple questions:

Are you using the recorder?
Which recorder are you using? (Desktop, Web, Citrix,Basic)
When you use the recorder which button are you clicking on to get started? (Open Browser, Click, Type, Copy, Element, Text, or Image)

If you’re not using the recorder, which Activities are you using, and in what order in the workflow?


#7

No I am not using a recorder.
I am using Type into activity. Here is the code. If you look at the very end, I cannot select specific boxes from the pop-ups. It works at the beginning but as oracle starts opening newer pop-ups it doesn’t recognize the new pop-up window.


#8

Here is my code. It didn’t get attached earlier. Please let me know if you have questions.

SendUiPath.xaml (30.0 KB)


#9

Do you have any work around for my “Type Into” activity not working at Oracle Application ? I sent you my code earlier this week ? Please let me know.

Thank You


#10

Can you also try the “Attach to Live Element” option in Selector editor? That should update your selector.
Or open UiExplorer and try adding specific parameters to the selector(in order to differentiate the pop-ups)

Or try adding < ctrl role=‘editable text’ > to the existing selector(this works especially for standard File Open dialog box).


#11

Ovi,
I have done UiExplorer and validating my selectors but it didn’t work.

I tried “Attach to Live Element” and this is the selector that came up. It is still not typing in the right field. How do I add < ctrl role=‘editable text’ > ? Can you please let me know ?

With Attached Live Element


Without attached to Live Element


Thank You


#12

@Anshu could you please retype the selectors again without the “<>” characters? It seems that the text disappears between these symbols.

Just paste that line to your selector editor. ex:
< wnd app=‘java.exe’ cls=‘SunAwtFrame’ title=‘Oracle Applications - PBN2OARF cloned from Production on 04-Jan-*’ />
< java idx=‘1’ name=‘Print Collection Reports’ role=‘internal frame’ />
< java idx=‘8’ role=‘panel’ />
< ctrl role=‘editable text’ >

It seems like since you have multiple pop-ups with the same selector of the boxes, it only types in the first one :frowning:


#13

Hi Anshul,
Hope you have found the solution of your Oracle automation.
If this solution pertains towards Oracle EBS, and your struggle is not over yet then please find the below solution that may help you.

I was working on Oracle EBS Application which gets instantiated by a clicking on a link of a web page, once oracle EBS is open i was unable to enter data using type Into activity.

Reason I found were:

  1. Selector were not getting created for text boxes
  2. Hardware incompatibility

Solution:
To capture right selector :Go to the form(where you need to work) at EBS, minimize all other forms present on the EBS GUI(do not close) they may be hiding behind any open form and then perform type into activity and indicate the required element , this will give you correct selector.
If you are unable to minimize other forms or popups then, drag your form towards an area where it should not overlap any other form or popup

"For Hardware Issue : please check if you are able to perform operations using 'send hot keys’in general…if not then you need to check for your keyboard and mouse drivers.


#14

For Oracle EBS , especially Applet windows , the selectors are not reliable. Especially when you have multiple windows open.

The way i did it for Oracle EBS , is to use Short Keys which are avaliable on almost all forms of Oracle , and use type into relying on the cursor position , instead of using selectors.

It turns out this ways , its very reliable. I was able to successfully execute a lot of workflows on Oracle EBS Screens with Shortkeys and Type into’s without explicitly providing selectors.

Hope this helps.


#15

Hi @sai.kiran

How do you use “Type into” based on cursor position? Your solution seems like the one that can solve my case: Oracle, multiple open windows and not being able to use selector.

Regards, Torben


#16

@Torben_Meldgaard ,

To test it out , Drag a type into in the workflow , dont give it any selector, and type in some text. once you run this workfloiw, The Type into will execute on whichever active window is found once the execution begins. If the type action completes (i.e if the type into found a notepad , or a window where you can type into ) you will see the result in the active window.

Now to use the type into without selector in EBS , Once you click on any form on the navigator , the applet window opens and the selected form would open in the applet, Notice the cursor position when the form loads. If you use type into at that point , it will type wherever the cursor is located.

So the best way to go about it would be ,

1.Attach window - Attach to the EBS Applet window , give a decent timeout so that the applet load time is compensated.

  1. Element exists - This will ensure the form is loaded before you type into it . Use the selector of the form. (Remember to get rid of idx elements in selector , and in some EBS forms , the Organization name is prefixed to the form name , in this case , use a wildcard (*) )

3.Type into + Hotkeys - Notice the cursor position when the window opens - and from then on , use type into and hot keys to Tab to next fields.

  • If you have to press a button somehwere on the form first approach i would suggest would be to try and use click , the trick is to ensure no other window is in the backrgound of the from / hiding behind the form. Drag the form to one of the extreme ends , ensure nothing else is beneath it … and use a click . if that works consistenty , its the best option.

Else , on the buttion label , there would be an Underscore against one of the lettes , thats an inidation of a hotkey which could be used. You could go ahead and invoke the button on a hot key.

Please do remember to use elememt exists whenever there is any processing happening. Either on button click or form load. This ensures application performance issues are well handled.

Hope this answers your question.


#17

Hi,

  • Use the Hotkey/shortcut key to reach the popup (by default once popup window open, control will focus on the same popup, if not then use the hotkey like Tab or special alphabets to move the focus on the window)

  • Once you reach to looking element/Text field use the type into to write content on it.

  • No need to add the Selector using the “Indicate on screen”.

  • Directly you can write the content in the field.


#18

how are you handling the pop ups
eg:. if i want to retreive the text from the pop like request id while submitting a concurrent request


#19

Once you submit conc request , use a get text activity to read the “request id” from the pop up , and then press okay, you might want to use wait for element activity to ensure any delays / performance issues are handled ,

and use string manupulation to retrive the request Id , by removing unwanted text before and after the conc request id .


#20

hi krishna,

thanks for the quick reply

but uipath is unable to handle the popups
the gettext activity unable to recognize the popups
it always gets the timeout exception for all the activities e.g typeinto, click, copytext etc…

and mainly its UIexplorer cannot recognize the popups it says following when i select the fields of the popup