Unable to pass URL as prompt for HTTP Request

I am trying to execute a workflow, where I use HTTP Request and perform GET Method. This workflow runs perfectly when I hardcode the URL.
But I want to pass the URL as user input. So I tried to pass user input to a variable. And from UrlSegments get these details for EndPoint as {Url}.
But it fails to execute by error message - HTTP Request: Invalid URI: The hostname could not be parsed.
Please let me know if I am missing anything here.

Hi @Vikas_Naidu

Make sure you are passing URL with out any extra qoute or other unsupported symbol.
Trying printing it in output pane and check or results.

Thanks Lakshay for response. I am passing same url as prompt which I was hardcoding before. There are no space where pass it from input dialog. The url has “-” and “.”, and same works perfectly fine when hard coded in EndPoint.

@Vikas_Naidu Try to put it in lor or write line and see if you see any discrepancy.

@Lakshay_Verma I checked using write line, the value passed in same.

@Vikas_Naidu
Best way to close it, you show your logs on what causing this issue or share your xaml file.
It needs more debugging

I checked the log file only this information is present -
11:01:03.2057 => [ERROR] [UiPath.Studio.Shared.Logging.OutputLogger] [80] HTTP Request: Invalid URI: The format of the URI could not be determined.

@Vikas_Naidu
Thanks for same, could you please share varaible output of URL or your workflow file.

@Lakshay_Verma It is project related url which needs specific access. I am trying to upload the workflow but it is not allowing me do so (new user). Is there any other option to share workflow file.

This is exact same error I get when I run the workflow. Here I am using HTTP Request Activity and passing link using URL SEGMENT (from parameter). I did preview which gave this error. If instead of abc I hardcode the values it is working.

Anyone has thoughts on how to do this. Is it possible to do so, please suggest.