Unable to open the .xaml file final error getting

I am getting the below error while opening the .xaml file of the project


Check this post,

Hi @balkishan,

I think you have created the process using Uiautomation 18.3 package and you would have updated the package to 19.2.0

Can you go back to 18.3.6897 package and try to open

@anil5 How I go back I have 19.2.0 so will it not be opening in the updated version of uipath.

There you have other versions when you select Uipath.UIautomation.Acitivities, select your version and click on update and after that try to open

@anil5 Not getting bro as the studio is up to date and simply I am opening a workflow but it’s not opening. I don’t have a much idea about what you said. Can you explain me more so that I can open the file.

when you open a new process in studio, then also you are getting the error if not, go to manage packages, go to uipath.UIautomation.activities and use your version and try to open your project

@balkishan do not first open your xaml file. Open Ui Path Studio seperately, create a new blank process in your 2019 version.

Then go to manage packages and make sure you downgrade UIAutomation activities to 18.3.6 as in the error.

Then open your xaml.

Please let me know if this solved your issue.

@ArunVelaayudhanG I am trying to save it but it’s not saved every time I select the lower version 18.3.66… It select and save also but when you go back and check same 19.2.0 version it’s showing.

This I selected but it showing me the updated version only


After selecting the version , click on update not save.

1 Like

You should click on update and then click on save.

@ArunVelaayudhanG @anil5 Not working did the same thing this package is opening in 18 version but in my colleague system it’s working fine they are also using the same version 19.2.0
. Not understand where is the issue.


I am also having problems opening '.xaml. files that are previously-created. Whether these files are created by me or are solutions (uncompressed) to the downloaded solutions to the practice problems on the REVAMP COURSE.

Specifically, I am getting the error below:-

Thank you very much.


-Dave Chandra

@balkishan install UiPath.Core.Activities . This should fix it i believe. Let me know.

@Dave_Chandra_US_Tax Restart you studio or close and open this, It will work fine. It’s not a problem.

1 Like

@ArunVelaayudhanG can you give me the exact name s I searched it’s doesn’t any result.

Hi @balkishan,

Thank you very much for replying so quickly - I really appreciate that.

I retried opening ‘.xaml’ files after closing/re-opening UiPath Studio but am still not able to do so. I actually also tried that before my earlier post, as that is what the error message indicated to do but I am still not able to access ‘.xaml’ files from my PC Desktop.

Below is the list of ‘error logs’ I get when I click on ‘Copy to Clipboard’ on this error box-from this, are you able to see what could be wrong?

Thanks, again!


  • Dave Chandra

@Dave_Chandra_US_Tax This is not the actual error sometime it happens. Can you try with restart your pc and open the studio again. If you have a single .xaml file to copy to the other location or on desktop and then open it surely it will open. May I know are you facing this issue with this particular file or all. Do the above and let me know.

@balkishan I did what you suggested to try to fix this issue but I am unable to open a lot of the files in .xaml format. (After powering off my PC, I waited two or three minutes before I powered back on my PC.)

I tried opening about five to eight files, just now, from my desktop, but only two of them opened, to be specific in what I just tried doing. For the files which are not opening, It is giving that same error that I posted an image of.

The two .xaml files which opened are from Lesson 3 of 13 of the REVAMP course, as I am very new to UiPath and am practicing workflow design. :):slightly_smiling_face::slightly_smiling_face:


  • Dave Chandra