Unable to open browser (Chrome) in foreground


Due to a certain system we use, which is most stable with Chrome, I had to automate a whole lot into this browser with extension.

After 5 months with stable code, the basic “open browser” seem to suddenly fail me. This is particulary bad since it’s the base of all automation within our online system.


  • Open browser Chrome, suddenly stays in background so selectors won’t work.
  • If I manually click anywhere before TimeoutMS - all the selectors work.
  • Once chrome is manually brought to foreground - everything works perfectly.
  • By being in the background I mean the icon is orange, the login page is still in foreground visually.
  • Reinstalled Chrome, extension, downgraded Chrome, upgraded Chrome, tried the Chrome 73 extension workaround.
  • I’ve tried workarounds such as “Activate”, “Maximize”, Minimize" etc. with little to no effect. I’ve even tried to send hotkeys to manually force chrome to the foreground.

Any solutions?

I need Open Browser to open Chrome actively - not just visually with blinking orange icons.


Hi @jornes

Can you please provide your Studio version, UIAutomation.Activities pack version and Chrome version so we can try to reproduce?

Of course!

  • Studio 2017, 1.6435 Enterprise Edition
  • W10 Pro 64-bit .NET 4.0.30319.42000
  • Chrome 74.0.3729.131 (64-bit)
  • UIPath.Core.Activities 17.1.6435.21841

Note that all the code works fine, except the open browser which had first error yesterday. It works if Chrome is already active (session running before Open browser - enable/disable new session has no effect) or if I click somewhere in the background.

Thought to check if updating remaining Activities could solve it - got an error.


Unable to update these atm:

Hi @jornes

Could you see my post here:

Thank you, but I am unable to use links in source, so I tried to link it to a web.config without any luck.

I am not sure if this is related to the most urgent issue with Chrome not being forced to foreground/workable. Would still be glad to fix this issue aswell.

See here for a detailed walk through for your version:

1 Like

After several failed attemps I did a clean reinstall, both windows and Uipath.

Thank you all for your help, but I think all my efforts and different “googled” solutions just made everything worse. All is good now!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.