Unable to logout from ACME_Login

Getting Attach Browser error while running the assignment in System1_Close.xaml.

"Attach Browser ‘iexplore.exe ACME’: Cannot find the UI element corresponding to this selector: "
I even tried by replacing selectors with wildcards but the same error getting again and again.

Hi @PrabhuViswa

Try to use Element exists


Element exists also tried when I run it seperately it works fine.I completed the whole Assignment 1 then run my Main workflow it getting this error!! …


I guess it’s not identifying the indicated screen. Could you please run the workflow in Debug mode and check it once.

Hello @PrabhuViswa
Actually problem not in system1_close workflow
If you are see output panel… system error occurred … due to this flow goes to end process. And selector not found error occurred.


HI @PrabhuViswa

Agree with what @sandeep13 mentioned. It looks like something is going wrong right after the login process completes. The best way to check for the root cause would be to run the process in debug mode. Have a break point right after the invoke workflow activity of the login workflow and do a step by step execution. It will help to locate where the problem is. Fixing this issue will fix the error in close applications unless there are errors specific to close applications.

1 Like

When I run it in debug mode I’m getting this information “Process finished due to no more transaction data”.

Check whether your queue has records with “new” status. If not clean the queue and add new data. Also try resetting the data in acme system

I’m not using the Orchestrator Queues and even after resetting the userdata in acme system the same thing occurs ie(Process finished due to no more transaction data).If you want I can send my work flow .

Also check whether you are assigning any value to out_transactionItem argument within the get transaction data xaml file. This is the main point where it checks whether it has any data to be processed. Can I see a screenshot of the segment where you assign the value to it?

Hello @PrabhuViswa

1 Like


I guess its not scraped data properly. Could you please print this value dt_WorkItems using Message box after assign Activity (After that Select query assisg Activity) and check whether it is showing any output or not.