Unable To login into Academy account

Not able to login into Academy Account
tried change password option stills its says incorret credentials

1 Like

Same has happened with me as well.Even after putting in the correct credentials,I could not login and the message that always popped up was “Incorrect Credentials”

@loginerror, @badita , @Pablito - Can you guys please take a look into this. Even I am facing the same issue.

Hi guys,
I will contact with proper team. Will let you know about any progress :slight_smile:

1 Like

Guys please try to use username instead of email. Let me know if this works.

I am not able to login into UiPath Academy even after several attempts at resetting my password.
I reset my password and use my browser to update the credentials, to make sure there is no typing mistake. But each time the Academy login page responds with ‘Wrong Credentials’ message.

did you enter email and password instead of username and password?

Hi @Mayank_Bhardwaj,
I moved your topic here. Please see information above.

Hi @Pablito - Both are not working.

Please try to reset password.

Hi @Mayank_Bhardwaj.

Try to Clear your browser cache and history, then try to reset your password.

Hope this helps.

Hi @Pablito - It is working now.


1 Like

I’m having the same issues. I had to reset my password 3 times… still nothing. How can I get this to work? I tried clearing the cache and still nothing.

Have you tried already with username or email?

Yea, I have tried it with both.

It just worked now with the username only.

1 Like

Hi, I am unable to login to the academy account. Tried resetting password and it is not triggering an email to me as well. Its been more than a week and I am trying all possible ways to troubleshoot which is stated as before, but nothing helps. Raised a case #00383574 where there is no response. Any help is appreciated! @Pablito

me too, seems to happen from time to time

If password reset is not providing you an email it seems that your account was not created based on Academy but with use of your already existed email. So if you are using SSO option to logon then we don’t have your password as it’s your email provided password.

Thank you for your reply @Pablito. I tried to re-register with the email id (but with different UserName) which triggered the activation email and now I am able to login to the Academy account.

Hope this helps someone!

1 Like