Unable to license cloud robot - Error: The remote certificate is invalid because of errors in the certificate chain: PartialChain

For latest version of Studio and Assistant, I am unable to sign in or connect the bot to cloud orchestrator.

The remote certificate is invalid because of errors in the certificate chain: PartialChain

Screenshot 2023-01-03 154043


Please check this


1 Like

Hi @Anil_G, I don’t have the SSL certificate because this is cloud Orchestrator and not on premise orchestrator.
Is there a way to get SSL certificate of cloud.uipath.com?


Okay …so its not certificate then…try checking if there is a antivirus /firewall available on your system then add cloud url as an exception


Try to download the Orchestrator certificate and add the certificate to the trusted root certificate of the robot machine.

Also, as last resort, after you installed the Orchestrator certificate in the robot machine, you may try to uninstall completely the robot from the impacted machine (for this follow this documentation Studio - Modify or Uninstall Studio) → restart the machine → reinstall again, and then retry the connection to Orchestrator.


Let us know if this helped.

1 Like

Hi @marian.platonov, will this be applicable to Cloud Orchestrator( cloud.uipath.com)?

@marian.platonov Also, as you can see the certificate for cloud.uipath.com is valid just for a day.

It should be applicable also. It seems that on the impacted robot machine, the Cloud Orchestrator certificate is not installed in the Trusted Root Certification Authorities path (certlm.msc tool).

Try to install this certificate on the robot machine.

sni cloudflaressl.zip (1.4 KB)

Let us know if this helped.

Also, show how you are connecting the robot to your Orchestrator. (From UiPath Assistant → Preferences → Orchestrator Settings)

Thanks @marian.platonov, would this need to be done daily as the certificate validity is 24 hours only.

I don’t think so.

Reference: SSL Checker

Reference: Comodo SSL Checker - SSL/TLS Certificates Checker Tool

Thank you so much @marian.platonov, let me try this and get back to you.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.