Unable to launch Robot outside of UiPath Studio - .bat solution

Hey team,
I created a robot in UiPath Studio, and I want to transfer it to another computer, so the attended robot can run on it.
I have a license and all UiPath Studio software on the machine where I want it to run. However, I want to launch the robot without opening the project in UiPath Studio.

I read several places that it can be launched using a .bat file, by using the filepath of the finished project and the filepath for the UiRobot.exe.
However, this is simply not working anymore. I’ve tried publishing the robot (More than 1 time) and launching the .nupkg file and I’ve tried launching the actual .xaml file in the folder. I’ve tried both versions of the UiRobot.exe - nothing is working.
The command prompt will open and close within a second, with no further action happening.
This is my input in the .bat file:
start “” “C:\Users\XXX\AppData\Local\UiPath\app-19.8.0\UiRobot.exe” /file:“C:\Users\DKLRT\Desktop\Test\Main.xaml”

Does anyone have an idea how I can launch my project without having to open the UiPath Studio?

Any help will be much appreciated!

Best Regards

  • Laurits :slight_smile:

Check this post @Laurits

1 Like

Wow - I hadn’t come across this post before.
I was certain I had looked at every single post regarding this - I really appreciate you pointing me in this direction!
Unfortunately, I need to request access to the .zip file - but I have sent a request now.
Have you implemented his solution, or were you just better at searching than me? :smiley:

I have the same working script for me now. I have included it in one of my code and it is running fine for me. .vbs script is something like exe file which will work on double click

That sounds like just the solution I need.
Can you make it available to me in a way? This way I don’t have to wait for him to accept my request.
It would be much appreciated :slight_smile:

Here is the file

Run UiPath Robot.zip (581 Bytes)

1 Like

You are a lifesaver. Thank you very much! :smiley:

Credits to @Guilherme_Mendes :slight_smile:

1 Like

Yes, works with no issues.
Thank you very much @Guilherme_Mendes!

You’re welcome my dear :wink:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.