Unable to invoke work flow

Hi Team,

While invoking workflow, I observed the below error.

Invoke Create_VDI workflow: The following errors were encountered while processing the workflow tree:
‘Create_VDI’: The private implementation of activity ‘1: Create_VDI’ has the following validation error: Compiler error(s) encountered processing expression “hostName”.
‘hostName’ is not declared. It may be inaccessible due to its protection level.

Things I have implemented:

  1. Read an excel file.
  2. Provided import arguments in the workflow.
  3. While invoking the workflow I observed the error.

Thanks,
Chaitanya.

Have you created the argument inside the invoked workflow?

yes I did.

Basically it tells you, that the variable ‘hostName’ i not declared.

If ‘hostName’ is the argument you are trying to import to the invoked workflow, please doublecheck, that you:
Import the argument in the ‘invoke workflow’ activity
And that inside the ‘Create_VDI’ workflow the argument is created and the direction/type is correct.

If you think everything looks in ordet, could you please share an image or the file

I did not imported any hostName argument. but still I am observing this issue. I will share the image.

Hi @ChaitanyaPanvalkar

Based on hostname you can give like this MachineName

Thanks
Ashwin S

Its not there in any arguments. Still it is showing

can you share the workflow so that we can look what is happening

@ChaitanyaPanvalkar Have you tried deleting the Invoke workflow and invoke the Workflow again?

Yes I tried that :slight_smile:

Extremely sorry. I am not able to share the workflow. its project sensitive data.

@ChaitanyaPanvalkar Can you make another Separate Sequence, and Copy the Whole Sequence From the Errored Workflow to this Sequence and Invoke the New Sequence as Workflow and Check, If it gives an error.

It;s Just Trial and Error method kind of Steos that you need to perform first and evaluate if it is working or not, then if it does not solve your problem, then something really needs to be :sweat_smile:

Tried with the same. But unable to fix the issue.

@ChaitanyaPanvalkar So All the Invoke Workflows have the same issue?

No. Only with the Create_VDI workflow.

Does Create_VDI has a variable"hostname"?

Open the Create_VDI work flow and Type “Hostname” in the search bar?If you find then see in crease the scope to whole workflow

And check whether it resolves the issue