Unable to install Uipath orchestrator on azure

Hello Friends
I am new to uipath.
I tried to install the orchestrator on my local machine with VMware workstation it works perfectly
however i am having problems deploying it on azure
I am following this method

It mentions this bit

  1. Create an Azure AD application and service principal that can access your Orchestrator [App Service and Resource Group]. Optionally, ask your friendly DevOps team to provide you with an Azure Service Principal ID and Password that can access the App Service and associated Resource Group.

I have full control at the Resource group level only and not at the subscription level
so i am unable to grant privilege to the service principal i created after registering the app in the app service .When i try to run the publish script it gives me the secret is wrong

| The provided account xxxxxxxxxxxxx
does not have access to subscription ID “xxxxxxxxxxx”.
Please try logging in with different credentials or a different subscription ID.

Another alternative to App registration is using managed identities but that also is not working as it seems it will not work for app services
Even if i use the Uipath template from the market place it ends up with the similar error

If any one has a full step by step procedure with screen shots it is greatly appreciated
with prerequisites
I tried this method

it is the same as the one in the doc .

Thanks in advance for taking time to read and respond.