Unable to install UIPath Community Edition on AWS EC2 Windows instance


Windows Installer(.exe): 18.4.1+Branch.master.Sha.bc66386dd8e2160b6d35f31d5ce934a5aa4cf4bd
License type(Free, Trial/License code): Community Edition - Free
Studio/Robot version: 18.4.1+Branch.master.Sha.bc66386dd8e2160b6d35f31d5ce934a5aa4cf4bd
Current behavior: Cannot use Community Edition on this machine after activating a trial or Enterprise license code. Please enter a valid license key.

Error information from screenshot above:

Activation failed with error: 0
Error description: Cannot use Community Edition on this machine after activating a trial or Enterprise license code. Please enter a valid license key.
License status: Device ID already activated

Device ID: +ZuoF1JeWSA1g8n46hGv
Computer: EC2AMAZ-89MDI1E
User Name: Administrator

1 Like


BTW - I neglected to mention that this is a brand-new instance on which I have never attempted to install UIPath. I am doing this as a POC that runs an automation I have built on my own machine, but need to make accessible to the rest of my team without them needing to install UIPath.

I attempted this yesterday on a different EC2 instance. Both the old and new instance had the same issue.
The instance is running Windows_Server-2016-English-Full-Base-2018.11.28

1 Like


Hello Dan. Not that this provides any assistance but just thought I would mention that I started a very similar post a few hours prior. Same issue - Studio Community Edition fails to activate stating that a prior install of an enterprise license was activated on the virtual machine when in fact that is not true - with the only difference being my attempt was on a fresh AWS Workspace instance while yours on an EC2 instance. Essentially identical issues. Hopefully one of us gets a reply from UiPath soon. May want to follow my post to check for updates. I will certainly continue to follow here too.

1 Like


Any luck from UI Path on this issue. Just had tried installing and found the same issue on AWS Workspace.



Hi @danderson @scott_carruthers @clebedeff

There is a workaround for it here:

The core of the issue comes from the fact that the machine gets license-locked in our licencing database by Device ID which is often shared between virtual machines.
More context here and here.

1 Like


My workaround was to force AWS to provide a different device id. If you spin up an instance, tear it down and spin up another instance, it will likely re-use the same device id. If you leave the old one up, and spin up another, you will get a different device id. It is possible that the new instance could have been registered with UIPath, so keep trying until it works. It is hacky, but it will work. There really should be a way to force deregistration of a device id, IMO



This worked for me as well. Initially I had tried using sysprep /generalize, but corrupted the workspace. I ended up spinning up a new workspace in a different region and now it seems to work fine. Thank you for the suggestion.




There is a way and it is to contact our licensing support. It is not guaranteed as the core of the restriction comes from the notion of tracking actual license utilization (to be able to serve a 60 day trial).

However, with enough background added to the ticket our support will be happy to help :slight_smile:



Hi Support team,

I have previously installed free or enterprise edition on my machine, Now i am trying to install community edition on the same machine after long time, but unable to install , please refer the below screenshot for the same,.

Please deactivate the mentioned device id from your end so that i can install community edition.
Device Id : jMezc69sLZpskxj9b47f



Hi @manohar

See here :slight_smile: