Unable to install all activities in Uipath

I have been trying to install Uipath multiple time but I am still getting errors as given below:

Failed to load assembly: C:\Users\amitd.nuget\packages\uipath.mail.activities/1.8.5\lib/net461/MimeKit.dll
Failed to load assembly: C:\Users\amitd.nuget\packages\uipath.mail.activities/1.8.5\lib/net461/UiPath.Mail.Activities.dll
Failed to load assembly: C:\Users\amitd.nuget\packages\uipath.mail.activities/1.8.5\lib/net461/UiPath.Mail.dll
Failed to load assembly: C:\Users\amitd.nuget\packages\uipath.system.activities/20.4.0\lib/net461/UiPath.OrchestratorClient.dll
Failed to load assembly: C:\Users\amitd.nuget\packages\uipath.system.activities/20.4.0\lib/net461/UiPath.System.Activities.dll

I do not know how I may resolve this issue, since I am unable to get access to Mail or Data extract wizard, and many others. DO let me know what the cause for this error, since I have uninstalled and re0installed the solution muktiple times.
regards
Amit

Hi Amit did you get the solution for the above error.As even i m getting the same error.

@amit.dasgupta This may due to write permissions to the UiPath nugget folder. Can you please manually go to the folder and check your user have read/write permission is on active or not. If not please provide the write permissions to the user and check it

@Ganesh_Preetam_Kopparapu I have checked the read/write permission and it has selected the write permission and below is the screensshot

Hi,

Are you getting the following error “Failed to load assembly” while creating new project in studio.

Yes, Below is the screenshot. Kindly let me know if there is any solution.

Could you please let me know are you opening this project with main.xaml or some customized name you have given for xaml.

@poonam_gupta

I hope the nuget packages service is not whitelisted.
Try the below steps and see

  1. Create a Folder Named Local packages in your machine

  2. Download the required packages from https://www.nuget.org/ and save it to local packages folder

  3. Go to manage packages and click settings and follow the below steps

  4. Add Name

  5. Add Local Packages path and click on add button

  6. In the Manage packages you can able to see the new created local packages

  7. Try to install the packages from there.

@kirankumar.mahanthi1
I’m opening the project with main.xaml.

@Ganesh_Preetam_Kopparapu
Hi,
I tried all the step mentioned by you but still getting the same error.

Can you tell me only specific process you are getting issue or every process?

Also can you please share your xaml if possible?

@Ganesh_Preetam_Kopparapu
This happens when ever i create a new project. Below is the attached file for your reference.
Main.xaml (3.2 KB)