Unable to get selectors for MYOB application

I’m unable to get any selectors for a table within an MYOB application called “PayGlobal”. The table has to be automated extensively. Does anyone know a way around this?

Here’s a screenshot of the application.

@Max.Randle - If selectors are not available, then an alternate way is to use Image Recording. Have you tried that?

I’m trying my best to avoid image based automation as some images are identical and the columns of the table are sensitive to screen resolution and layout. It will not make for a reliable bot in this case.

Hi @Max.Randle

You can still try to run your Studio as administrator (sometimes works) and to change the UI Framework
(it’s possible that one of the available ones will catch the selctors)

Thanks for the suggestion, I’ve tried both of those things and neither works :confused: I guess the application doesn’t expose any selectors for the table.

Could you still see the actual tree in UiExplorer?

Sometimes it is possible to spot elements inside of the top level element that you can then double click to create your selector.

For example, if the main window it selects would be Firefox, maybe you can open the tree and double click on the menu bar to create your selector. Just an idea.