Unable to Get Asset from Orchestrator. Exception Message: Forbidden

orchestrator
studio

#1

Scenario:

Trying to retrieve an Asset or Credential from Orchestrator. My Robot and Orchestrator are linked, and processes can be run on the robot from Orchestrator. These Assets can be accessed by others on Orchestrator. I have double chacked the Roles available to Robot and View Assets is checked. I have tried different versions of UiPath.Credentials.Activities as well as restarting UiPath and my machine.

Steps to reproduce:

  1. Set up an Asset or Credential on Orchestrator.
  2. Get Asset/ Get Credential Activity and enter the name of the Asset/Cred into AssetName field.
    3.Run Workflow

Current Behavior:

I receive the following error message:
GetAssets has thrown an exception

Source: Get Asset

Message: Forbidden

Exception Type: OrchestratorHttpException

UiPath.Core.Activities.OrchestratorHttpException: Forbidden
at UiPath.Core.Activities.HttpStatusCodeExtension.OrchestratorEnsureStatusCode(HttpResponseMessage response)
at UiPath.Core.Activities.BaseAssetActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

Expected Behavior:

Asset should be returned as a string.

Studio/Robot/Orchestrator Version:

Studio 2018.2.0


#2

@Raspoutine: From the system tray, can you go to the robot setting and disconnect the bot and retry connecting to the orchestrator. And kindly validate the Robot credentials in the orchestrator, could it be possible that you are using a different account when running the robot.

I assume you also have an output variable to hold the result from the asset.


#3

Thanks PD2, unfortunately I have disconnected and reconnected the robot as suggested, and the robot credentials have been validated.
The same error is occurring.

Other accounts on the Orchestrator can retrieve the asset.

And I have the outputs set in the Studio.


#4

did you change the roles of the Robot user?


#5

No, These are the roles for the Robot users, and remain unchanged.

Other Robots can still retrieve the Asset.