Unable to find selectors for 'WindowsForms10.Window' application

Hi all,

I’m trying to create a robot to run a set of processes on an application. The application is used in my workplace and for that reason I am unable to disclose what it is, but what I can say is that the application is - ‘WindowsForms10.Window’ and when I try to select it, the entire window is highlighted but no data is returned.

Likewise, it can’t recognise any of the individual elements within the application either.

UIExplorer can see that the application is open on my desktop and the following details are displayed about it but nothing else is returned:

Has anyone seen this before/have a solution?

Any help would be appreciated.


@amccusker Can you try Citrix recording in this case if selectors are not getting identified by UiExplorer.

Hi @amccusker, that application is most probably running elevated (i.e. with admin rights). For security reasons, UiPath running in non-admin mode cannot read selectors from an application running in a higher integrity level.

For development purposes, you can circumvent this by running Studio elevated (right click on studio icon / Run as Administrator).

If the issue reappears at runtime (when running the process on a UiPath robot, which does not run as admin), you can do one of the following:

Hope this helps.

Hi @Madhavi_Jaiswal , thanks for the suggestion. Sadly Citrix doesn’t work on it either. Thanks.

Hi @mihaira, thanks for getting back to my query. I will look in to this and let you know how it works out. Thanks.

I ran UiPath Studio as admin and it was able to recognise the UI Elements within the application meaning that it does in fact have elevated permissions. I created a small sequence spying each element and tried to run the sequence again but in ‘non-admin’ UiPath. It no longer works.

Error message I receive:

I need to now establish whether I can continue to run robot with Admin permissions or change the target application to lesser permissions.

Thank you all for the help.