Unable to find library nuget package(Reusable component) while running the job from orcestrator

Hi All,

I have to work on a project in which I have used a library package for the reusability of code and published that package into the production. When I run the process from the studio, it is working fine, but when I run it through the orchestrator it is throwing the error message like Unable to find the library NuGet package.

Can anyone help me out to fix this issue?

Thanks in Advance.

Hi @Shivaraju ,

Quick questions:

  • Are you using the same machine to run Studio and receive the job from Orchestrator? Or from Orchestrator you are using a 2nd machine?
  • Are you’re always connected to the same Orchestrator? (You said something about pushing it to production, are you using different orchestrators for PRD and Dev?)
    – If so, check if on the Orchestrator your PRD bot is connected, if the package (or library) is available.

Note: If you’re connected to the machine and you trigger it from Orchestrator, it will act as Attended. If you’ve signed out, it will act as unattended.

If you have 2 separated machines, you might have firewall blocking connections to the Package Sources listed below:

Info on Ports permissions:

Also, if none of the above solves the issue, could you send the error message you’re receiving, and send a screenshot of your Package sources?

Hope this helps!

I am having a similar issue. I have a Reusable Library for interacting with Gsuite components. It was working fine for me for many iterations, but now it seems my robot is unable to find it past a certain revision level.

Here is the error code I get from Orchestrator when the job tries to run but fails.

You can see it’s referencing specifically version

The problem goes away when I downgrade the library to

I even went as far as to download the known good and republish it with no changes, and I still get the same error. Is there a limit to the number of library versions that can coexist on Orchestrator?