Unable to find custom nuget package via Orchestrator Robot

uiautomation
orchestrator
robot
activities
studio

#1

Cusom activities i am able to use it via Studio but after publishing the project to orchestrator, robot is not able to find the custom nuget package.

Robot has extracted the process nuget package in path : -
C:\Users\raj.nuget\packages\Reports-downloading\1.0.6762.26715. Inside that there is .json file is there as : AllDependencies.json
and in that all nuget package i found below logs : -
{
“code”: “NU1101”,
“level”: “Error”,
“message”: “Unable to find package uipath.custom.activities. No packages exist with this id in source(s): Gallery, https://demo.uipath.com/nuget/activities, https://demo.uipath.com/nuget/feed/raj, Local”,
“libraryId”: “uipath.custom.activities”,
“targetGraphs”: [
“.NETFramework,Version=v4.5.2”
]
}
]
}
Can anyone help me…


Custom Activities deployment issue
#2

I hope this will help! :smiley:


#3

But in that system, there is no UiPath Studio software then how can i go to manage packages option?


#4

Maybe this might help!
i guess what you have to do is that you will have to manually put the custom activities inside the computer!


#5

Could you try uploading the packages in the same feed where the processes are located. For platform you don’t have access to the activities feed therefore the robot should point to a feed where these are located.

@Gabriel_Tatu


#6

The best way to do this is to put the packages on the local feed of the robot, manually.
Robot checks for the needed package on Orchestrator feed, but for Community you can t add it yourself.


#7

I got it by placing the nuget package file in programdata - uipath - package folder.

There was an mistake on my nuget package. Id name in nuget package
: Before I named it as Ultimate Suite, it didn’t worked. Then I changed as excel.custom.activities but this also didn’t worked.

Finally I changed it as Custom.Actvities then it worked perfectly.
So xyz.Activities should be there as Id in nuget package.

Thank you all and Mihai


#8

It works but you need to uncheck “Filter Activities” in package manager.


#9

That’s right Mihai, but in robot system we don’t have any studio, so how you will be able to do it…


#10

The robot needs to have access to a feed where the activity is deployed. This can be achieved by

  • adding a custom feed in nuget config of the robot or
  • adding the activity to the Orchestrator activities feed (can’t be achieved on platform.uipath.com)

#11

Hi Badita,
Can you please explain with an example(pictures)? So that it would be clear to everyone.

Thank you!


#12

I’ve been getting deeper into this issue lately and trying to understand the nuances.

UiPath have produced some relatively good documentation about it. I think anyone who wants to understand how activities & feeds work should start there:

https://robot.uipath.com/docs/about-the-activities-feed

https://robot.uipath.com/v2017.1/docs/about-the-activities-feed

If you read and understand those pages as a foundation, Badita’s comments above will make perfect sense.

One thing I haven’t been able to find in the documentation is how & when UiPath Studio creates the list of activities dependencies in the settings.json file, which I presume is the driver for which activities get downloaded when the robot runs.


#13

Hi @ octechnologist
The dependencies part of the project.json is written when you publish (to either local or Orchestrator) the workflow.

Now, about what is written there : all the packages you currently have installed (from Studio), even if you do not use them in your current flow, are written there, in the dependecies part of project json. Inefficient, I know, but this is fixed in the current 18.3 version that we are working on.

Hope this helps,
-Andrei