Unable to enumerate list on BoardGameGeek web site

Using Studio v2021.10.4.

On web site boardgamegeek.com, you can do an advanced search for games by publisher. Simply select “Advanced Search” from the “Search” box, then all the searchable fields appear. Enter “Victory” in the “Publisher/Manufacturer” text box. A list of potentially matching Publishers appear. I’m trying to capture that list of Publishers and enumerate through them.

Not sure how to make this happen. I tried using a “Find Children” activity, but that does not work. Can anyone offer suggestions?


Hi @mark.dagosta

here you go
BoradGameGeek.xaml (13.4 KB)

note: for Click Serarch Box activity I’ve set “SendWindowsMessage” as “True”

Hope this is helpful

Hi @mark.dagosta ,

Please have a look at the above link if it solves your purpose.


Thanks Aditya! I’ll review this tonight and get back to you.

Thanks Shikhar! I’ll review this tonight and get back to you with the results.

Aditya, I received an error when attempting to open your BoradGameGeek.xaml file: “Could not find member ‘AutomaticallyDownloadWebDriver’ in type ‘http://schemas.uipath.com/workflow/activities:OpenBrowser’. Row 70, Column 21”

Do you know which reference/version I’m missing?


I suspect that the error is because of version mismatch in the packages.

my studio version is 2021.10.4
and packages as below

my suggestion is don not open this xaml in already existing project, instead you copy the xaml to a seperate folder and launch studio by double clicking on this xaml, so this will create correct poject.json and you might not have the error

let me know if this worked

you can work with:

  • find children
  • data scraping

for data scraping case have a look here:

Thanks Aditya. I updated my packages and the error is gone. However, the original problem still remains. I’m unable to capture the list of items in the search popup. Best regards, Mark

Thanks Shikhar, but no luck. The FindChildren activity does not recognize this as an enumerable list. It just returns a single blank “item” in the results. Best regards, Mark

did you set “SendWindowsMessage” as “True” ?
if this didn’t work, set SimulateClick to True and “SendWindowsMessage” as “False”