Unable to download UiPath.IntelligentOCR.Activities package

i am trying to download intelligent ocr package from all packages but its showing some error and unable to download and it keeps downloading.

1 Like

Hi @ankur_kaushik2
are you able to dwnld other package

if yes, try downloading one lower version

if NO, restart studio and try again

Hello @ankur_kaushik2
What is the version that you are trying to download

Add these sources to your User defined package sources/Default package sources and retry to download the UiPath.IntelligentOCR.Activities[6.3.1-preview]:



Let us know if adding the above package sources to your Manage Packages ribbon helped to download and install the UiPath.IntelligentOCR.Activities[6.3.1-preview] package.

yes others getting download.
except that all good.

tried all approaches.

its top most preview version.

can you please elaborate how to do it, where it is default package ?

You can specify here C:\Program Files\UiPath\Studio\NuGet.config (the install folder of your UiPath Studio).

Results in UiPath Studio:


Also, you may check to not have enabled TLS 1.3, as NuGet and MyGet do not support TLS 1.3. Enabling the protocol causes a handshake failure error when connecting to the services.

Reference: Services Studio Connects To

How to manage the TLS on your machine? → Software requirements

Let us know if this helped.

i got this config but i didnt find it on the path u told.
is it the same?

skip above replies, i got same config.

i changed accordingly but getting error

Double-check your Nuget.Config file as you have some incorrect setup for some keys.

<?xml version="1.0" encoding="utf-8"?>
    <!-- Add this repository to the list of available repositories -->
    <add key="Local" value="C:\Program Files\UiPath\Studio\Packages" />
	<!--  <add key="Local" value="C:\local feed path" /> -->
    <add key="Marketplace" value="https://www.myget.org/F/workflow/api/v3/index.json" />
    <add key="Connect" value="https://gallery.uipath.com/api/v2" />
    <add key="Official" value="https://packages.uipath.com/activities" />
    <add key="nugetorg" value="https://api.nuget.org/v3/index.json" />
    <add key="signatureValidationMode" value="accept" />

okay i fixed all of the changes you asked for but now its again back to first ss i showed error. :no_mouth:

Are you having a proxy on your machine in place?
UiPath Studio type (Community/Enterprise)?
UiPath Studio version?
How do you install the Studio (in user mode or in service mode)?
Are you having access to the internet on the UiPath Studio machine?
Show us the content of the uipath.config file from your UiPath Studio installation folder path.
Provide us the today’s Execution logs from your UiPath Studio application (Ctrl + L) → We need to see and understand your encountered errors during the package download.

version and downloaded it from UiPath tab.

and its community stable version.
and i using vpn provided by organization.
i didnt understand user/service mode.
and i have internet connection viz is working well cuz i can download other packages.

New Text Document.txt (55.5 KB)
here are the logs

New Text Document.txt (1.3 KB)
uipath config file

It is installed in User Mode (Per-user Installation).


You provided the Execution log where no download activity is present. Please provide all the logs from today after pressing Ctrl + L from your UiPath Studio.


Try to change the uipath.config to this:

<?xml version="1.0" encoding="utf-8"?>
    <section name="connectionSettings" type="System.Configuration.AppSettingsSection" />
    <section name="communicationSettings" type="System.Configuration.AppSettingsSection" />
    <section name="packageSettings" type="System.Configuration.AppSettingsSection" />
    <section name="sessionSettings" type="System.Configuration.AppSettingsSection" />
    <section name="analyticsSettings" type="System.Configuration.AppSettingsSection" />
    <section name="webProxySettings" type="System.Configuration.AppSettingsSection" />
    <section name="robotCacheSettings" type="System.Configuration.AppSettingsSection" />
    <section name="robotJsSettings" type="System.Configuration.AppSettingsSection" />
    <add key="defaultServiceUrl" value="https://cloud.uipath.com" />
    <add key="maxMessageSizeInMegabytes" value="50" />
    <add key="installPackageTimeout" value="00:20:00" />
    <add key="requestTimeout" value="00:00:40" />
    <add key="disableSecureXaml" value="True" />
  <sessionSettings />
  <analyticsSettings />
  <webProxySettings />
  <robotCacheSettings />
  <robotJsSettings />


Try to disable temporary the VPN and retry the download. It may be that your organization didn’t whitelist the needed package sources hostnames.

Reference: Services the Robot Connects to

New Text Document.txt (365.1 KB)
i have 4 log files i pasted them in one and top most file i sent you ,please find relevant one.

and i have already tried following approaches:

-download studio directly from cloud.uipath.
-download from cloud.uipath resource center stable one.
-download package turning off VPN.
-download package stable version ,other lower version
-download package from myget website and put in package folder then download from local tab packages it worked but when i am trying to open other workflows in which intelligent ocr higher version is used then its failing to open.

just now tried vpn turn off and download pack. but failed.